View Issue Details

IDProjectCategoryView StatusLast Update
0002111XdebugUncategorizedpublic2022-08-19 08:12
Reporteraideeaidee Assigned To 
PrioritynormalSeverityblockReproducibilityalways
Status newResolutionopen 
Product Version3.2.0alpha2 
Summary0002111: entrypoint zend_get_parameters_array_ex not found
Description

Actually I'm not sure if I should report this as PHP is in beta and XDebug is in beta, but I wanted to try it. I used the windows binary. Assigned the dll in the php.ini (XDEBUG) session:

[xdebug]
zend_extension ="C:\xampp\php\phsp_ext\php_xdebug-3.2.0alpha1-8.2-vs16-x86_64.dll"
xdebug.mode=profile,develop,debug
xdebug.start_with_request = trigger
xdebug.client_port = 9000
xdebug.profiler_output_name = cachegrind.out.%t.%p
xdebug.output_dir ="C:\xampp\tmp"
xdebug.show_local_vars=1

But apache gives an error: Failed loading C:\xampp\php\phsp_ext\php_xdebug-3.2.0alpha1-8.2-vs16-x86_64.dll

Running the PHP windows version I get an error message:

'cant find entry point of procedure _zend_get_parameters_array_ex in DLL C:\xampp\php\phsp_ext\php_xdebug-3.2.0alpha1-8.2-vs16-x86_64.dll'

This procedure works fine in all older PHP environments.

Perhaps I'm way too early, so if this post is inappropiate, please delete.

Steps To Reproduce

PHP 8.2 beta, recent Xampp, 3.2.0.alpha XDebug.

Possible mismatch between versions is the cause of this issue. (my bad).

Additional Information

I'm using PHP 8.2 beta

Tagsentry-point
Operating SystemWindows 10
PHP Version8.2-dev

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2022-08-19 08:12 aideeaidee New Issue
2022-08-19 08:12 aideeaidee Tag Attached: entry-point