View Issue Details

IDProjectCategoryView StatusLast Update
0002135XdebugStep Debuggingpublic2022-11-10 09:50
Reporterbarel Assigned Toderick  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformUbuntu 
Product Version3.1.5 
Target Version3.2devFixed in Version3.2.0RC2 
Summary0002135: Xdebug stops twice at the same line after a call breakpoint or xdebug_break()
Description

When stopping in a function after a call breakpoint and then doing a step_into or step_over it will stop at the same line

Steps To Reproduce

Run test xdebug/tests/debugger/bug01007.phpt. This is the output of some of the commands:

-> run -i 2
<?xml version="1.0" encoding="iso-8859-1"?>
<response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug&quot; command="run" transaction_id="2" status="break" reason="ok"><xdebug:message filename="file://bug01007-simpleclass.inc" lineno="13"></xdebug:message></response>

-> step_into -i 3
<?xml version="1.0" encoding="iso-8859-1"?>
<response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug&quot; command="step_into" transaction_id="3" status="break" reason="ok"><xdebug:message filename="file://bug01007-simpleclass.inc" lineno="13"></xdebug:message></response>

What I would expect to see:

-> run -i 2
<?xml version="1.0" encoding="iso-8859-1"?>
<response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug&quot; command="run" transaction_id="2" status="break" reason="ok"><xdebug:message filename="file://bug01007-simpleclass.inc" lineno="13"></xdebug:message></response>

-> step_into -i 3
<?xml version="1.0" encoding="iso-8859-1"?>
<response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="https://xdebug.org/dbgp/xdebug&quot; command="step_into" transaction_id="3" status="break" reason="ok"><xdebug:message filename="file://bug01007-simpleclass.inc" lineno="14"></xdebug:message></response>

What we see is that the debugger stops at line 13 after reaching the call breakpoint (which is correct) but then after running step_into we are still at line 13 and I would expect us to be at line 14 (since line 13 contains a single statement)

TagsNo tags attached.
Operating System
PHP Version7.4.30-7.4.39

Activities

Issue History

Date Modified Username Field Change
2022-11-03 16:55 barel New Issue
2022-11-04 16:00 derick Assigned To => derick
2022-11-04 16:00 derick Status new => acknowledged
2022-11-10 08:53 derick Target Version => 3.2dev
2022-11-10 08:53 derick Summary Xdebug stops twice at the same line after a call breakpoint => Xdebug stops twice at the same line after a call breakpoint or xdebug_break()
2022-11-10 08:53 derick Note Added: 0006446
2022-11-10 09:08 derick Status acknowledged => closed
2022-11-10 09:08 derick Resolution open => fixed
2022-11-10 09:08 derick Fixed in Version => 3.2dev
2022-11-10 09:50 derick Fixed in Version 3.2dev => 3.2.0RC2