View Issue Details

IDProjectCategoryView StatusLast Update
0000220XdebugUsage problems (Wrong Results)public2006-11-27 21:54
Reporterd_kelseyAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000220: PHP.exe crashes when the script ends
DescriptionThis bug can also be reproduced on PHP 5.1.4.

I have 2 scripts
testcase3.php and file1.php

testcase3.php
-------------
<?php
$a = array (1,
         array (2,
             array (3,
                 array (4,
                     array (5,
                         array (6,
                             array (7,
                                 array (8)
                            )
                        )
                    )
                )
            )
        )
    );

echo var_dump($a);
echo "hi";
?>

file1.php
---------
<?php
/*
 * Created on 11-Sep-2006
 *
 * To change the template for this generated file go to
 * Window - Preferences - PHPeclipse - PHP - Code Templates
 */
 
echo 'hello';
echo 'dave';

$a='Well hello There';
echo $a;

phpinfo();

?>

Using the debug client I enter the following commands

cmd set
-------
breakpoint_set -i 25 -t line -f file:///C%3a/temp/xdebugBug/testcase3.php -n 18
breakpoint_set -i 26 -t line -f file:///C%3a/temp/xdebugBug/file1.php -n 13
feature_set -i 31 -n max_depth -v 3
run -i 33
context_get -i 36 -d 0
run -i 41

A problem is then reported by Microsoft windows and offers me the option to send or don't send the report to Microsoft
Additional InformationNote that it is important that you must set both breakpoints even though file1.php is never called. You must do the feature set and you must do a context get. It is always reproduceable using this set of commands and these files. I have tried other files and only setting a single break point and the problem doesn't occur.

I can stop the problem by setting the max_depth to 10 (for example) or by not setting max_depth at all (but I need to allow a user to specify max_depth).

if I set max_depth to a value of 4, then I get the trap when I attempt the context_get command. I have not tried any other value of max_depth apart from 10.
TagsNo tags attached.
Operating SystemWindows XP
PHP Version5.2.0

Activities

derick

2006-11-21 19:47

administrator   ~0000489

I tried to reproduce this on LInux (with valgrind) with php 5.2.0 and the latest CVS release of Xdebug, but I couldn't find a single memory corruption issue (which is what your report would suggest). Perhaps you could try the latest snapshot version? (from http://pecl4win.php.net/ext.php/php_xdebug.dll)

d_kelsey

2006-11-23 16:35

reporter   ~0000495

ok, a new day a reboot of the machine and now I cannot recreate the problem, strange because when debugging with my client I observed the problem and PHP script was being launched in it's own process every time and was recreatable every time. I recreated the issues outside of my debug environment with the xdebug client, but I cannot recreate it now in that environment either. Maybe I managed to have a rogue extension somewhere being loaded ?

derick

2006-11-27 21:54

administrator   ~0000499

That is possible as windows keeps dlls in memory. I will close the report now, but feel free to reopen if you can recreate it.

Issue History

Date Modified Username Field Change
2006-11-21 13:28 d_kelsey New Issue
2006-11-21 19:47 derick Note Added: 0000489
2006-11-21 19:47 derick Status new => feedback
2006-11-23 16:35 d_kelsey Note Added: 0000495
2006-11-27 21:54 derick Status feedback => resolved
2006-11-27 21:54 derick Resolution open => unable to reproduce
2006-11-27 21:54 derick Assigned To => derick
2006-11-27 21:54 derick Note Added: 0000499
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)