View Issue Details

IDProjectCategoryView StatusLast Update
0000248XdebugUsage problems (Wrong Results)public2007-03-30 15:23
ReporterfelixAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000248: Xdebug redundantly outputs errors
DescriptionBasically the following settings have to be set for php:

display_errors = On
log_errors = On
error_log = syslog

I am running things as an apache module.

Errors should go to one place only and thats the syslog. Currently the error is outputted both to the Apaches configured error_log file and to the systems syslog.

I believe this is a bug because php without xdebug will log errors in one location and that is the syslog. I imagine xdebug should work similarly.
TagsNo tags attached.
Operating SystemLinux
PHP Version5.2-dev

Activities

felix

2007-03-19 23:09

reporter   ~0000579

I dont think this is a bug I though it was but after doing another test its not.

felix

2007-03-20 21:44

reporter   ~0000580

I do have a problem where the stack trace is repeated in the error log. This i am getting with php4.4.4 and xdebug 2.0rc3. The settings are I specified already. I'll debug this a bit more later to see what is happening.

felix

2007-03-22 04:52

reporter   ~0000581

This was a problem in rc3 it seems and fixed in cvs. I guess you can close this bug than.

derick

2007-03-30 15:23

administrator   ~0000582

Okay, thanks for checking it out!

Issue History

Date Modified Username Field Change
2007-03-19 05:30 felix New Issue
2007-03-19 23:09 felix Note Added: 0000579
2007-03-20 21:44 felix Note Added: 0000580
2007-03-22 04:52 felix Note Added: 0000581
2007-03-30 15:23 derick Status new => resolved
2007-03-30 15:23 derick Resolution open => unable to reproduce
2007-03-30 15:23 derick Assigned To => derick
2007-03-30 15:23 derick Note Added: 0000582
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)