View Issue Details

IDProjectCategoryView StatusLast Update
0000250XdebugUsage problems (Wrong Results)public2007-04-03 15:47
ReportermathieukAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0000250: XDebug 2.0RC3 doesn't report error conditions
DescriptionXDebug 2.0RC3 doesn't report any errors when an error occurs.

Consider the following script:
<?php

$test = "test";
waa();

?>

This should raise an undefined function error.

Configuration:
========================================================
No special configuration options set.

Expected behaviour:
========================================================
When running the above script through debugclient-0.9.0, after issueing the 'run' command, xdebug should reply with a <response> element indicating a problem (status=aborted?). It probably needs a <error> element aswell, containing the error message.

Actual behaviour:
========================================================
The script runs and when it runs into the error, xdebug reports the script now has the 'stopped' state with 'reason=ok':

debugclient-0.9.0 transcript:
-----------------------------

Connect
<?xml version="1.0" encoding="iso-8859-1"?>
<init fileuri="file:///data/home/mathieu/public_html/xd/index.php" language="PHP" protocol_version="1.0" appid="9507" idekey="waa"><engine version="2.0.0RC3"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[http://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2007 by Derick Rethans]]></copyright></init>
(cmd) run -i waa
<?xml version="1.0" encoding="iso-8859-1"?>
<response command="run" transaction_id="waa" status="stopped" reason="ok"></response>
(cmd)

Additional Information(FYI, the PHP version select in Mantis' Report Bug form doesn't have 5.2.1 as an option yet.)
TagsNo tags attached.
Operating SystemTested on Windows & Linux
PHP Version5.2.0

Activities

mathieuk

2007-04-03 09:05

reporter   ~0000583

Same issue occurs with xdebug-cvs:

Transcript:

mathieu@ubuntu:~$ ./debugclient-0.9.0
Xdebug Simple DBGp client (0.9.0)
Copyright 2002-2004 by Derick Rethans.
- libedit support: enabled

Waiting for debug server to connect.
Connect
<?xml version="1.0" encoding="iso-8859-1"?>
<init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" fileuri="file:///home/mathieu/public_html/xdebug/index.php" language="PHP" protocol_version="1.0" appid="6950" idekey="waa"><engine version="2.0.0RC4-dev"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[http://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2007 by Derick Rethans]]></copyright></init>
(cmd) run -i waa
<?xml version="1.0" encoding="iso-8859-1"?>
<response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="run" transaction_id="waa" status="stopped" reason="ok"></response>

derick

2007-04-03 15:47

administrator   ~0000584

This is not a bug. In order for the debugger to stop on error or warning conditions, you need to set a breakpoint on them. You can do that with:

breakpoint_set -i 71 -t exception -x "Fatal error"

Issue History

Date Modified Username Field Change
2007-04-02 09:15 mathieuk New Issue
2007-04-03 09:05 mathieuk Note Added: 0000583
2007-04-03 15:47 derick Status new => resolved
2007-04-03 15:47 derick Resolution open => no change required
2007-04-03 15:47 derick Assigned To => derick
2007-04-03 15:47 derick Note Added: 0000584
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)