View Issue Details

IDProjectCategoryView StatusLast Update
0000263XdebugFeature/Change requestpublic2007-07-31 22:11
ReporterjunAssigned Toderick 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0000263: Warning for setting breakpoint on no-code lines
DescriptionWhen I set breakpoint on source line where there is no code,
the response of the breakpoint_set command does not complain
about that. It seems okay, but the execution never stops at
the line.

I wish that the response of breakpoint_set command says
"hey you are setting breakpoint on no-code line" or something
like that. So a debug client can be able to issue warning
to the user.
TagsNo tags attached.
Operating System
PHP Version5.1.6

Relationships

duplicate of 0000200 closed Add the retrieval of a file's execution lines in DBGp 

Activities

derick

2007-07-31 22:11

administrator   ~0000710

I am closing this as duplicate of bug 0000200. The functionality in this report is impossible as I can only access this information if the script has already been parsed.

Issue History

Date Modified Username Field Change
2007-05-01 06:16 jun New Issue
2007-05-01 11:25 derick Category Debug client (console) => Feature/Change request
2007-07-31 22:11 derick Status new => resolved
2007-07-31 22:11 derick Resolution open => duplicate
2007-07-31 22:11 derick Relationship added duplicate of 0000200
2007-07-31 22:11 derick Assigned To => derick
2007-07-31 22:11 derick Note Added: 0000710