View Issue Details

IDProjectCategoryView StatusLast Update
0000285XdebugUsage problems (Wrong Results)public2007-07-14 14:55
ReportergshAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformOSDebianOS Version
Product Version2.0.0dev 
Target VersionFixed in Version 
Summary0000285: 2.0.0RC4 and auto_prepend_file
DescriptionIf there is a php auto_prepend_file directive, only that file is profiled.
Steps To Reproduceset auto_prepend_file directive to some legit file.
Profile some other scripts where the auto_prepend applies.
Check the cachegrind output, you'll see that only the auto_prepended_file was profiled.
Additional InformationThis worked fine in RC3 and before
TagsNo tags attached.
Operating System
PHP Version5.2.1

Activities

derick

2007-07-07 21:59

administrator   ~0000677

I can not reproduce this with 2.0.0rc5-dev. I made a .htaccess with:

php_value auto_prepend_file prepend.php
php_value xdebug.profiler_enable 1

and two files:
prepend.php:

<?php
strlen("prepend");
echo "prepend
\n";
?>

index.php:

<?php
strlen("index");
echo "index.php\n";
?>

The generated profile correctly shows two calls to strlen() and the "source" file shows both prepend.php and index.php (the latter inlined).

derick

2007-07-14 14:55

administrator   ~0000693

And no feedback, because the given email address is a one-shot address.

Issue History

Date Modified Username Field Change
2007-06-18 18:12 gsh New Issue
2007-07-07 21:59 derick Note Added: 0000677
2007-07-07 21:59 derick Status new => feedback
2007-07-14 14:55 derick Status feedback => resolved
2007-07-14 14:55 derick Resolution open => unable to reproduce
2007-07-14 14:55 derick Assigned To => derick
2007-07-14 14:55 derick Note Added: 0000693
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)