View Issue Details

IDProjectCategoryView StatusLast Update
0000287XdebugStep Debuggingpublic2020-03-12 17:19
ReporterjamesAssigned Toderick 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0000287: debugging static class variables
DescriptionReported feature request as requested
TagsNo tags attached.
Operating System
PHP Version5.1.6

Relationships

duplicate of 0000623 closedderick Static properties of a class can be evaluated only with difficulty 

Activities

jeffg

2007-09-05 16:54

reporter   ~0000722

This feature is requested for Komodo IDE as well, here is a test script that can be used to repro the problem:

<?php

class testclass {
    static private $name;
    
    static public function show_name() {
        //do something with $name
        self::$name = "Sir John\n" . self::$name;
        return self::$name;
    }
}

echo testclass::show_name();

?>

To repro, but a breakpoint at line 9. The value of self::$name is not visible.

derick

2012-01-25 09:39

administrator   ~0001896

Duplicate of 0000623, which is now fixed.

Issue History

Date Modified Username Field Change
2007-06-25 12:37 james New Issue
2007-09-05 16:54 jeffg Note Added: 0000722
2012-01-25 09:39 derick Note Added: 0001896
2012-01-25 09:39 derick Relationship added duplicate of 0000623
2012-01-25 09:39 derick Status new => resolved
2012-01-25 09:39 derick Resolution open => duplicate
2012-01-25 09:39 derick Assigned To => derick
2020-03-12 16:55 derick Severity major => feature
2020-03-12 17:19 derick Category Feature/Change request => Step Debugging