View Issue Details

IDProjectCategoryView StatusLast Update
0000029XdebugUsage problems (Wrong Results)public2003-12-01 15:15
ReporterquinxyAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000029: the params info returned from xdebug_get_function_trace() is incomplete
DescriptionThe structure returned by a call to xdebug_get_function_trace() is returning only the last parameter in each function call, in the example I provide, the print_r() of the xdebug_get_function_trace() shows only the parameter "t3" in the call to test(). This is obviously not correct.
Additional Information<?php
xdebug_start_trace();


function test($t1,$t2,$t3) {
}

test("t1","t2","t3");

print_r(xdebug_get_function_trace());
?>
TagsNo tags attached.
Operating SystemRedhat 7.3
PHP Version4.3.2

Activities

derick

2003-11-19 17:11

administrator   ~0000060

Which Xdebug version do you use? This works for me, but I have to set xdebug.collect_params=1 in php.ini. Can you also give me the php.ini settings for xdebug that you have?

Derick

quinxy

2003-11-19 18:41

reporter   ~0000061

i tried it with xdebug.collect_params in php.ini and the error still occcurred. as for version, it was the version i said in the ticket. as for the php.ini options, nothing to see.

all i had in it was the line to load the shared library.

at different times i did put in the lines to automatically do it for every page/etc. but I had the same results. you're saying that even if you turned off those in php.ini you couldn't reproduce the problem?

anyway... it's no longer critical for me. i wrote a wrapper for your dump html version, and i just regular expression through that to get the valid data.

derick

2003-11-20 11:13

administrator   ~0000062

Right, I can't reproduce this at all. How exactly did you load Xdebug from php.ini?

derick

2003-11-24 10:11

administrator   ~0000065

Reminder sent to quinxy

Hello,

can you please tell me how you load Xdebug in your php.ini file?

regards,
Derick

derick

2003-12-01 15:15

administrator   ~0000066

Can not reproduce this at all...

Issue History

Date Modified Username Field Change
2003-11-14 00:44 quinxy New Issue
2003-11-19 17:11 derick Note Added: 0000060
2003-11-19 17:11 derick Status new => feedback
2003-11-19 18:41 quinxy Note Added: 0000061
2003-11-20 11:13 derick Note Added: 0000062
2003-11-24 10:11 derick Note Added: 0000065
2003-12-01 15:15 derick Status feedback => resolved
2003-12-01 15:15 derick Resolution open => unable to reproduce
2003-12-01 15:15 derick Assigned To => derick
2003-12-01 15:15 derick Note Added: 0000066
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)