View Issue Details

IDProjectCategoryView StatusLast Update
0000296XdebugFeature/Change requestpublic2007-07-19 18:55
ReporterFlorentGAssigned Toderick 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionwon't fix 
Product Version 
Target VersionFixed in Version 
Summary0000296: Change in profile time representation causes WinCacheGrind to report wrong execution time
DescriptionAs written in the update, xDebug 2.0.0.RC4 uses "µ seconds instead of a tenths of µ seconds to avoid confusion in profile information."

However, WinCacheGrind still uses tenths of µ seconds. The reported execution time is then divided by ten, I get for example a 31 ms execution time for a script that actually take 310 ms.

Even if it is more a WinCacheGrind problem, Win32 users have no alternative to display profile files, and it seems to be no longer updated :( Would it be possible to have a configuration option to switch between µ and tenth of µ ?
TagsNo tags attached.
Operating SystemWindows XP SP2
PHP Version5.2.1

Activities

derick

2007-07-19 18:55

administrator   ~0000700

I will not change this back. Xdebug 2 was always in beta, and this was a bug in Xdebug - it is unfortunately that WinCacheGrind is no longer updated, but that is something I can not fix :)

Issue History

Date Modified Username Field Change
2007-07-19 09:38 FlorentG New Issue
2007-07-19 18:55 derick Status new => resolved
2007-07-19 18:55 derick Resolution open => won't fix
2007-07-19 18:55 derick Assigned To => derick
2007-07-19 18:55 derick Note Added: 0000700