View Issue Details

IDProjectCategoryView StatusLast Update
0000308XdebugUsage problems (Wrong Results)public2009-10-17 18:14
ReportertachuAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000308: Var dump displaying cut strings.
DescriptionWhen you have a string with new lines in it var dump will cut it off. This is not related to the lenght of the string it will always cut off. For better understanding see example below.
Additional InformationWith String:
$sql = "SELECT media_group.title, media_group.description, media_content.url, media_content.duration,
 media_content.title AS contentTitle, media_content.description AS contentDescription,
 media_group_thumbnail.url as thumbnailUrl FROM media_group, media_content,media_group_thumbnail
 WHERE (14,14,44) AND media_content.media_group_id=media_group.id AND media_group.id=media_group_thumbnail.media_group_id
 group by media_content.id";

  var_dump($sql);

the output is :
string 'SELECT media_group.title, media_group.description, media_content.url, media_content.duration,
 media_content.title AS contentTitle, media_content.description AS contentDescription,
 media_group_thumbnail.url as thumbnailUrl FROM media_group, media_content,media_group_thumbnail
 WHERE (14,14,44) AND media_content.media_group_id=media_group.id AND media_group.id=media_group_thumbnail.media_group_id
 group by ' (length=426)

Now Same string no new lines:
 $sql = "SELECT media_group.title, media_group.description, media_content.url, media_content.duration, media_content.title AS contentTitle, media_content.description AS contentDescription, media_group_thumbnail.url as thumbnailUrl FROM media_group, media_content,media_group_thumbnail WHERE (14,14,44) AND media_content.media_group_id=media_group.id AND media_group.id=media_group_thumbnail.media_group_id group by media_content.id";

  var_dump($sql);
string 'SELECT media_group.title, media_group.description, media_content.url, media_content.duration, media_content.title AS contentTitle, media_content.description AS contentDescription, media_group_thumbnail.url as thumbnailUrl FROM media_group, media_content,media_group_thumbnail WHERE (14,14,44) AND media_content.media_group_id=media_group.id AND media_group.id=media_group_thumbnail.media_group_id group by media_content.id' (length=422)

TagsNo tags attached.
Operating SystemCentOS Release 5 (final)
PHP Version5.1.6

Activities

tachu

2007-09-13 18:05

reporter   ~0000724

Also consider adding more character to string at end of string actually print out more.

  $sql = "SELECT media_group.title, media_group.description, media_content.url, media_content.duration,
 media_content.title AS contentTitle, media_content.description AS contentDescription,
 media_group_thumbnail.url as thumbnailUrl FROM media_group, media_content,media_group_thumbnail
 WHERE (14,14,44) AND media_content.media_group_id=media_group.id AND media_group.id=media_group_thumbnail.media_group_id
 group by media_content.id asdf asdf adsf asdf asdf asdf asdf asdf asdf asdf asdf asdf asdf asdf ";

  var_dump($sql);

outputs:
string 'SELECT media_group.title, media_group.description, media_content.url, media_content.duration,
 media_content.title AS contentTitle, media_content.description AS contentDescription,
 media_group_thumbnail.url as thumbnailUrl FROM media_group, media_content,media_group_thumbnail
 WHERE (14,14,44) AND media_content.media_group_id=media_group.id AND media_group.id=media_group_thumbnail.media_group_id
 group by media_content.id asdf asdf adsf asdf asdf asdf asdf asdf asdf asdf asdf' (length=497)

derick

2007-10-28 20:42

administrator   ~0000778

I can not reproduce this at all, could you please send me a reproducing script by mail - in a tar.gz or zip file. And also post the output of phpinfo() somewhere?

derick

2007-11-01 21:07

administrator   ~0000794

Reminder sent to tachu

I can not reproduce this at all, could you please send me a reproducing script by mail - in a tar.gz or zip file. And also post the output of phpinfo() somewhere?

derick

2007-11-11 17:41

administrator   ~0000806

Reminder sent to tachu

I can not reproduce this at all, could you please send me a reproducing script by mail - in a tar.gz or zip file. And also post the output of phpinfo() somewhere?

This is the last reminder that I will send. If I don't get feedback I will mark it has "unable to reproduce".

derick

2009-10-17 18:14

administrator   ~0001110

No feedback provided -> closing issue.

Issue History

Date Modified Username Field Change
2007-09-13 18:03 tachu New Issue
2007-09-13 18:05 tachu Note Added: 0000724
2007-10-28 20:42 derick Note Added: 0000778
2007-10-28 20:42 derick Status new => feedback
2007-11-01 21:07 derick Note Added: 0000794
2007-11-11 17:41 derick Note Added: 0000806
2009-10-17 18:14 derick Note Added: 0001110
2009-10-17 18:14 derick Status feedback => resolved
2009-10-17 18:14 derick Resolution open => unable to reproduce
2009-10-17 18:14 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)