View Issue Details

IDProjectCategoryView StatusLast Update
0000314Xdebug(No Category)public2007-10-27 19:25
ReporterrgpjonesAssigned To 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0000314: PHP CLI Error Logging thwarted when XDebug Loaded
DescriptionPHP Error Logging from CLI scripts is thwarted when the XDebug module is loaded. This does not happen if the XDebug module is not included.
Additional InformationConsider:
<?php
trigger_error('Error', E_USER_ERROR);

When run through the php cli it shows an error on screen (with display_errors=on), but no error is logged to the PHP error log.
If the XDebug module is disabled then PHP CLI behaves as expected.

I'm experiencing this issue on Debian Lenny (testing) with PHP 5.2.3, and XDebug 2.1-dev, but my friend has the same issue on Debian Etch (stable) with XDebug 2.0.0. I've also experienced this issue with XDebug 2.0.0RC4.

I can make a full 'php -i' available on request.
TagsNo tags attached.
Operating SystemDebian Lenny
PHP Version5.2-dev

Activities

rgpjones

2007-10-05 13:46

reporter   ~0000735

Sorry, I raised this in "Debug Client". I meant "Usage Problems"

rgpjones

2007-10-10 17:48

reporter   ~0000736

Sorry... this is a dupe of 0000232

If you are experiencing this issue then you need to edit the source code:

file: xdebug.c
function: log_stack
remove the if clause:
if (is_cli) {
    return;
}

Recompile and install:
phpize
./configure --enable-xdebug
make
sudo make install

derick

2007-10-27 19:25

administrator   ~0000771

Fixed in CVS, thanks for your report!

Issue History

Date Modified Username Field Change
2007-10-05 13:45 rgpjones New Issue
2007-10-05 13:46 rgpjones Note Added: 0000735
2007-10-10 17:48 rgpjones Note Added: 0000736
2007-10-27 19:25 derick Status new => closed
2007-10-27 19:25 derick Note Added: 0000771
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)