View Issue Details

IDProjectCategoryView StatusLast Update
0000319XdebugInstallationpublic2007-10-27 17:57
Reporterjpr1965Assigned Toderick 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000319: error message of php -m /etc/httpd/modules/xdebug.so: undefined symbol: php_sprintf
Descriptionerror after installing xdebug.so:

calling php -m and you get the following error message

/etc/httpd/modules/xdebug.so: undefined symbol: php_sprintf
Additional InformationPHP 4.3.9 (cgi) (built: May 4 2007 11:04:14)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
TagsNo tags attached.
Operating SystemRedHat V4
PHP Version4.3.11

Activities

derick

2007-10-21 11:47

administrator   ~0000745

What is your full configure line?

jpr1965

2007-10-22 07:10

reporter   ~0000746

I didn't configure anything, I just copied the .so file into the apache modules directory and started check, how written in installation instruction of Active State Komodo.

Which configuration do you mean and how do I get the configure line?

derick

2007-10-22 08:15

administrator   ~0000748

PHP's configure line... you can see it by checking the output of the phpinfo() call.

jpr1965

2007-10-22 12:07

reporter   ~0000751

Here is the php info line...

'./configure' '--build=i686-redhat-linux-gnu' '--host=i686-redhat-linux-gnu' '--target=i386-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--enable-force-cgi-redirect' '--disable-debug' '--enable-pic' '--disable-rpath' '--enable-inline-optimization' '--with-bz2' '--with-db4=/usr' '--with-curl' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--with-gd=shared' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-ncurses=shared' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-png' '--with-pspell' '--with-xml' '--with-expat-dir=/usr' '--with-dom=shared,/usr' '--with-dom-xslt=/usr' '--with-dom-exslt=/usr' '--with-xmlrpc=shared' '--with-pcre-regex=/usr' '--with-zlib' '--with-layout=GNU' '--enable-bcmath' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-track-vars' '--enable-trans-sid' '--enable-yp' '--enable-wddx' '--with-pear=/usr/share/pear' '--with-imap=shared' '--with-imap-ssl' '--with-kerberos' '--with-ldap=shared' '--with-mysql=shared,/usr' '--with-pgsql=shared' '--with-snmp=shared,/usr' '--with-snmp=shared' '--enable-ucd-snmp-hack' '--with-unixODBC=shared,/usr' '--enable-memory-limit' '--enable-shmop' '--enable-calendar' '--enable-dbx' '--enable-dio' '--enable-mbstring=shared' '--enable-mbstr-enc-trans' '--enable-mbregex' '--with-mime-magic=/usr/share/file/magic.mime' '--with-apxs2=/usr/sbin/apxs'

derick

2007-10-27 17:57

administrator   ~0000769

There must be something wrong with how this module was compiled, because when I do it myself it works just fine:

derick@kossu:~/dev/php/php-4.3.9$ sapi/cgi/php -v
PHP 4.3.9 (cgi) (built: Oct 27 2007 18:50:04)
Copyright (c) 1997-2004 The PHP Group
Zend Engine v1.3.0, Copyright (c) 1998-2004 Zend Technologies
    with Xdebug v2.1.0-dev, Copyright (c) 2002-2007, by Derick Rethans

Perhaps you should contact the Active State people about this (and feel free to point them to this report of course).

Issue History

Date Modified Username Field Change
2007-10-19 11:10 jpr1965 New Issue
2007-10-21 11:47 derick Note Added: 0000745
2007-10-21 11:47 derick Status new => feedback
2007-10-22 07:10 jpr1965 Note Added: 0000746
2007-10-22 08:15 derick Note Added: 0000748
2007-10-22 12:07 jpr1965 Note Added: 0000751
2007-10-27 17:57 derick Status feedback => resolved
2007-10-27 17:57 derick Resolution open => unable to reproduce
2007-10-27 17:57 derick Assigned To => derick
2007-10-27 17:57 derick Note Added: 0000769