View Issue Details

IDProjectCategoryView StatusLast Update
0000327XdebugUsage problems (Wrong Results)public2007-10-27 17:10
ReporterMikeDAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0000327: xdebug.var_display_max_* values are ignored in remote usage
Descriptionrunning xdebug for remote debugging, however it seems that the xdebug.var_display_max_children, xdebug.var_display_max_data, xdebug.var_display_max_depth settings in php.ini are ignored and internal default values are used. Note that these internal values used are different from the normal defaults

xdebug.var_display_max_data:
normal default: 512
php.ini setting: 2048
queried value: 1024

xdebug.var_display_max_children
normal default: 128
php.ini setting: 2048
returned value: 32

xdebug.var_display_max_depth
normal default: 3
php.ini setting: 20
returned value: 1

workaround:
when debugging session launches send these DBGp commands to reset the configurations to the desired values:

feature_set -i 1 -n max_children -v <value>
feature_set -i 2 -n max_data -v <value>
feature_set -i 3 -n max_depth -v <value>

Additional Informationphp.ini:
xdebug.var_display_max_children 2048
xdebug.var_display_max_data 2048
xdebug.var_display_max_depth 20

phpinfo() output:
xdebug.var_display_max_children 2048 128
xdebug.var_display_max_data 2048 512
xdebug.var_display_max_depth 20 3

output from debugclient-0.9.0.exe:

Waiting for debug server to connect.
Connect
<?xml version="1.0" encoding="iso-8859-1"?>
<init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" fileuri="file:///home/miked/htdocs/y.php" language="PHP" protocol_version="1.0" appid="89417" idekey="session_name"><engine version="2.0.0"><![CDATA[Xdebug]
]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[http://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2007 by Derick Rethans]]></copyright></init>

(cmd) feature_get -i 1 -n max_children

<?xml version="1.0" encoding="iso-8859-1"?>
<response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_get" transaction_id="1" feature_name="max_children" supported="1">
    <![CDATA[32]]>
</response>

(cmd) feature_get -i 1 -n max_depth

<?xml version="1.0" encoding="iso-8859-1"?>
<response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_get" transaction_id="1" feature_name="max_depth" supported="1">
    <![CDATA[1]]>
</response>

(cmd) feature_get -i 1 -n max_data

<?xml version="1.0" encoding="iso-8859-1"?>
<response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_get" transaction_id="1" feature_name="max_data" supported="1">
    <![CDATA[1024]]>
</response>

(cmd) quit
Disconnect


Waiting for debug server to connect.
TagsNo tags attached.
Operating System
PHP Version5.1.2

Activities

derick

2007-10-27 17:10

administrator   ~0000766

This is not a bug, those three settings are not supposed to work on remote debugging. The defaults need to be different as it is a bad idea to have a depth != 1 for remote debugging, while it also cumbersome to deal with var_dump() displays if the depth = 1 there. I updated the documentation for those 3 settings to make this a bit clearer.

Issue History

Date Modified Username Field Change
2007-10-26 15:13 MikeD New Issue
2007-10-27 17:10 derick Status new => resolved
2007-10-27 17:10 derick Resolution open => no change required
2007-10-27 17:10 derick Assigned To => derick
2007-10-27 17:10 derick Note Added: 0000766
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)