View Issue Details

IDProjectCategoryView StatusLast Update
0000033XdebugUsage problems (Wrong Results)public2004-03-16 23:36
ReporterzyxAssigned To 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0000033: Apache crashes with static methods
DescriptionI've got some static methods in my PHP 5 (today's snapshot) code. I tried to run it with xdebug. It crashed Apache 2, when PHP ended executing first called static method.
TagsNo tags attached.
Operating SystemWindows XP
PHP Version5.0.0-dev

Relationships

has duplicate 0000038 resolvedderick Xdebug segfaults with __destruct() 

Activities

derick

2003-12-21 12:53

administrator   ~0000081

Can you please provide a sample script so that I can try to reproduce it? And do I understand correctly that you compiled the latest Xdebug (from CVS) for Windows yourself?

zyx

2003-12-23 09:46

reporter   ~0000083

I found the reason of the problem - Xdebug crashes, when I try to create an object of class with destructor. I was creating a lot of classes without destructors and they were working without errors. But when I added a destructor ( function __destruct(){ ), PHP and Apache 2 were crashing on line

$object = new class_with_destructor;

Here is the sample:

<?php

    class any_class{
        function __destruct(){
        
        }
    
    }

    $object = new any_class;
?>

BTW. I downloaded XDebug binaries from this site. I'd have to download newest PHP 5 sources to compile it myself, because my actual sources are from June or July.

derick

2003-12-23 10:40

administrator   ~0000084

Okay, this is a known problem. Actually it's something buggy in PHP with the shutdown order, and not in Xdebug. I'll keep this bugreport though.

derick

2004-03-16 23:36

administrator   ~0000108

Fixed in latest PHP CVS and Xdebug CVS.

Issue History

Date Modified Username Field Change
2003-12-21 09:21 zyx New Issue
2003-12-21 12:53 derick Note Added: 0000081
2003-12-21 12:53 derick Status new => feedback
2003-12-23 09:46 zyx Note Added: 0000083
2003-12-23 10:40 derick Note Added: 0000084
2003-12-23 10:40 derick Status feedback => acknowledged
2004-01-05 09:20 derick Relationship added has duplicate 0000038
2004-03-16 23:36 derick Status acknowledged => closed
2004-03-16 23:36 derick Note Added: 0000108
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)