View Issue Details

IDProjectCategoryView StatusLast Update
0000331XdebugUsage problems (Wrong Results)public2017-01-03 18:50
ReportermattisAssigned Toderick 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0000331: assert() in code produses wrong return from xdebug_get_code_coverage()
Description<?php
class wrongoutput {
    public function __construct() {
        xdebug_start_code_coverage(XDEBUG_CC_UNUSED | XDEBUG_CC_DEAD_CODE);
        
        new someotherclass();
        
        $data = xdebug_get_code_coverage();
        
        xdebug_stop_code_coverage();
        
        var_dump($data);
    }
}

class someotherclass {
    public function __construct() {
        $j = 2;
        assert('$j >= 0');
    }
}

new wrongoutput();
Additional Informationphp wrongreturn.php
array(2) {
  ["C:\Projects\Eclipse\Worspace-zend\CrashXdebug\wrongreturn.php(19) : assert code"]=>
  array(1) {
    [1]=>
    int(1)
  }
  ["C:\Projects\Eclipse\Worspace-zend\CrashXdebug\wrongreturn.php"]=>
  array(9) {
    [4]=>
    int(-1)
    [6]=>
    int(1)
    [8]=>
    int(1)
    [10]=>
    int(-1)
    [12]=>
    int(-1)
    [13]=>
    int(-1)
    [18]=>
    int(1)
    [19]=>
    int(1)
    [20]=>
    int(1)
  }
}
TagsNo tags attached.
Operating SystemWindows XP
PHP Version5.2.4

Activities

derick

2016-12-09 00:24

administrator   ~0003966

What is wrong here?

derick

2017-01-03 18:50

administrator   ~0004130

I could not reproduce this, and no additional information was presented. I am therefore closing this report.

Issue History

Date Modified Username Field Change
2007-10-31 16:14 mattis New Issue
2016-12-09 00:24 derick Category Feature/Change request => Usage problems (Wrong Results)
2016-12-09 00:24 derick Note Added: 0003966
2016-12-09 00:24 derick Assigned To => derick
2016-12-09 00:24 derick Status new => feedback
2017-01-03 18:50 derick Note Added: 0004130
2017-01-03 18:50 derick Status feedback => resolved
2017-01-03 18:50 derick Resolution open => no change required