View Issue Details

IDProjectCategoryView StatusLast Update
0000346XdebugInstallationpublic2008-04-18 18:32
Reporterrakesh139Assigned Toderick 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0000346: Can not load xDebug as Zend Extension
DescriptionI compiled Xdebug from source, copied the same in my PHP extension directory and tried to load the same as Zend Extension. But this is not working (I don't see it either in phpinfo() or php -m).

But this loads as normal PHP extension.
i.e.
Works:
extension=xdebug.so

Does not work:
zend_extension_ts="/usr/local/php5/lib/php/extensions/xdebug.so"

Please suggest.

Thanks.

Rakesh

Additional InformationApache version 2.2.6
PHP 5.2.4 compiled from source as Apache Module.
PHP Configure line:

'./configure' '--with-apxs2=/usr/local/apache2/bin/apxs' '--prefix=/usr/local/php5' '--with-config-file-path=/usr/local/php5' '--with-pear=/usr/php5/share' '--with-filepro' '--with-xsl' '--enable-xslt' '--with-xslt-sablot' '--with-xml=/usr/local/libxml2' '--enable-exif' '--enable-ftp' '--enable-bcmath' '--enable-calendar' '--with-gd' '--enable-gd-native-ttf' '--with-freetype-dir=/usr' '--with-db4-dir=/usr/local' '--with-gettext' '--with-zlib' '--enable-trans-sid' '--with-kerberos' '--with-imap-ssl' '--with-openssl=/usr' '--enable-sysvsem' '--enable-sysvshm' '--enable-calendar' '--enable-sysvmsg' '--enable-track-vars' '--with-dom' '--with-mcrypt' '--with-mhash' '--with-iconv' '--enable-mbstring=all' '--enable-mbregex' '--with-png-dir=/usr' '--with-jpeg-dir=/usr' '--with-mysql=/usr/local/mysql' '--with-mime-magic' '--enable-trans-sid' '--enable-bcmath' '--with-bz2' '--enable-ctype' '--with-regex' '--with-mysqli=/usr/local/mysql/bin/mysql_config' '--with-curl'
TagsNo tags attached.
Operating SystemUbuntu Feisty 7.04
PHP Version5.2.4

Activities

rakesh139

2008-02-11 12:21

reporter   ~0000827

I just upgraded my PHP version to 5.2.5 and Xdebug got loaded as Zend Extension.

Seems to be an issue with version 5.2.4.

Rakesh

derick

2008-04-18 18:32

administrator   ~0000838

Marking as "not a bug" then.

Issue History

Date Modified Username Field Change
2008-01-07 07:48 rakesh139 New Issue
2008-02-11 12:21 rakesh139 Note Added: 0000827
2008-04-18 18:32 derick Status new => resolved
2008-04-18 18:32 derick Resolution open => no change required
2008-04-18 18:32 derick Assigned To => derick
2008-04-18 18:32 derick Note Added: 0000838