View Issue Details

IDProjectCategoryView StatusLast Update
0000362XdebugUsage problems (Wrong Results)public2009-11-22 17:12
ReporterYoguiAssigned Toderick 
PrioritynormalSeverityblockReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000362: Superglobal overwritten by local variable
DescriptionI am not sur how to reproduce this bug.
I am developing a Zend Framework application. I have a $_POST['tags'] superglobal variable and also a $tags local object. When I put a breakpoint to inspect $_POST, its 'tags' offset shows me $tags instead. However, if i var_dump($_POST), I find my original data untouched.
Additional InformationThe object I am speaking of is an extension of Zend_Db_Table.
I am using Apache 2.0.59.
TagsNo tags attached.
Operating SystemWindows XP SP2
PHP Version5.2.5

Activities

Yogui

2008-04-11 17:15

reporter   ~0000830

I forgot: I am using PHPEdit 2.12.8 as a client to Xdebug.

derick

2009-11-22 17:12

administrator   ~0001159

I just tried this with a very simple script:

<?php
$tags = 42;

echo $tags, "\n", $_POST['tags'], "\n";
?>
<form method="POST">
<input name="tags">
<input type="submit">
</form>


But it works fine, i get the correct results in both watches for $_POST and $tags, as well as in the Locals and Superglobals tabs in Komodo. I suspect a PHPEdit bug here.

Issue History

Date Modified Username Field Change
2008-04-11 17:13 Yogui New Issue
2008-04-11 17:15 Yogui Note Added: 0000830
2009-11-22 17:12 derick Note Added: 0001159
2009-11-22 17:12 derick Status new => resolved
2009-11-22 17:12 derick Resolution open => unable to reproduce
2009-11-22 17:12 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)