View Issue Details

IDProjectCategoryView StatusLast Update
0000372XdebugInstallationpublic2008-05-05 08:08
ReporterstephaneeybertAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000372: Cannot compile xdebug. make gives error 1.
DescriptionDear all,

I tried to install xdebug 2.0.3 from source on Kubuntu 8.04 with php-4.3.11 sitting in /home/stephane/programs/install

I have the gcc
gcc --version
gcc (GCC) 4.2.3 (Ubuntu 4.2.3-2ubuntu7)

I ran the following command:

./configure --enable-xdebug --prefix=/home/stephane/programs/install --with-php-config=/home/stephane/programs/install/bin/php-config

Then I did a make and got

/bin/bash /home/stephane/programs/xdebug-2.0.3/libtool --mode=compile gcc -I. -I/home/stephane/programs/xdebug-2.0.3 -DPHP_ATOM_INC -I/home/stephane/programs/xdebug-2.0.3/include -I/home/stephane/programs/xdebug-2.0.3/main -I/home/stephane/programs/xdebug-2.0.3 -I/home/stephane/programs/install/include/php -I/home/stephane/programs/install/include/php/main -I/home/stephane/programs/install/include/php/TSRM -I/home/stephane/programs/install/include/php/Zend -DHAVE_CONFIG_H -g -O0 -c /home/stephane/programs/xdebug-2.0.3/xdebug_code_coverage.c -o xdebug_code_coverage.lo
gcc -I. -I/home/stephane/programs/xdebug-2.0.3 -DPHP_ATOM_INC -I/home/stephane/programs/xdebug-2.0.3/include -I/home/stephane/programs/xdebug-2.0.3/main -I/home/stephane/programs/xdebug-2.0.3 -I/home/stephane/programs/install/include/php -I/home/stephane/programs/install/include/php/main -I/home/stephane/programs/install/include/php/TSRM -I/home/stephane/programs/install/include/php/Zend -DHAVE_CONFIG_H -g -O0 -c /home/stephane/programs/xdebug-2.0.3/xdebug_code_coverage.c -fPIC -DPIC -o xdebug_code_coverage.lo
/home/stephane/programs/xdebug-2.0.3/xdebug_code_coverage.c: In function 'xdebug_find_jump':
/home/stephane/programs/xdebug-2.0.3/xdebug_code_coverage.c:148: error: 'union <anonymous>' has no member named 'jmp_addr'
/home/stephane/programs/xdebug-2.0.3/xdebug_code_coverage.c: In function 'prefill_from_oparray':
/home/stephane/programs/xdebug-2.0.3/xdebug_code_coverage.c:233: warning: assignment makes pointer from integer without a cast
/home/stephane/programs/xdebug-2.0.3/xdebug_code_coverage.c: In function 'prefill_from_function_table':
/home/stephane/programs/xdebug-2.0.3/xdebug_code_coverage.c:272: warning: comparison between pointer and integer
/home/stephane/programs/xdebug-2.0.3/xdebug_code_coverage.c: In function 'xdebug_prefill_code_coverage':
/home/stephane/programs/xdebug-2.0.3/xdebug_code_coverage.c:312: warning: comparison between pointer and integer
make: *** [xdebug_code_coverage.lo] Error 1
Additional InformationThe output of the configure command:

checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc and cc understand -c and -o together... yes
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking for PHP prefix... /home/stephane/programs/install
checking for PHP includes... -I/home/stephane/programs/install/include/php -I/home/stephane/programs/install/include/php/main -I/home/stephane/programs/install/include/php/TSRM -I/home/stephane/programs/install/include/php/Zend
checking for PHP extension directory... /home/stephane/programs/install/lib/php/extensions/no-debug-non-zts-20020429
checking for re2c... exit 0;
checking for gawk... no
checking for mawk... mawk
checking whether to enable eXtended debugging support... yes, shared
checking for gettimeofday... yes
checking for cos in -lm... yes
checking for ld used by GCC... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking for a sed that does not truncate output... /bin/sed
checking whether ln -s works... yes
checking how to recognise dependent libraries... pass_all
checking command to parse /usr/bin/nm -B output... ok
checking how to run the C preprocessor... gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking for ranlib... ranlib
checking for strip... strip
checking for objdir... .libs
checking for gcc option to produce PIC... -fPIC
checking if gcc PIC flag -fPIC works... yes
checking if gcc static flag -static works... yes
checking if gcc supports -c -o file.o... yes
checking if gcc supports -c -o file.lo... yes
checking if gcc supports -fno-rtti -fno-exceptions... no
checking whether the linker (/usr/bin/ld) supports shared libraries... yes
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking dynamic linker characteristics... GNU/Linux ld.so
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no
checking whether -lc should be explicitly linked in... no
creating libtool
configure: creating ./config.status
config.status: creating config.h
config.status: config.h is unchanged
TagsNo tags attached.
Operating SystemKubuntu 8.04
PHP Version4.3.11

Relationships

has duplicate 0000412 resolvedderick make: *** [xdebug_code_coverage.lo] Error 1 

Activities

derick

2008-05-05 08:08

administrator   ~0000850

This is fixed in CVS already, but you should seriously consider upgrading PHP. PHP 4.3.11 has both security issues and is just generally really old (more than 3 years).

Issue History

Date Modified Username Field Change
2008-05-04 23:00 stephaneeybert New Issue
2008-05-05 08:08 derick Status new => resolved
2008-05-05 08:08 derick Resolution open => fixed
2008-05-05 08:08 derick Assigned To => derick
2008-05-05 08:08 derick Note Added: 0000850
2008-12-20 19:53 derick Relationship added has duplicate 0000412