View Issue Details

IDProjectCategoryView StatusLast Update
0000383XdebugUsage problems (Wrong Results)public2009-11-27 17:05
ReporterAlexanderLAWAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityrandom
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0000383: PHP crash: PHP has encountered an Access Violation at 01948493
DescriptionFrom time to time i'm getting forementioned error.
Additional InformationAfter installing WinDBG I found that violation occurs at:

php_xdebug_2_0_3_5_2_5!xdebug_init_oparray:
01948470 6a00 push 0x0
01948472 6a00 push 0x0
01948474 ff1570929501 call dword ptr [php_xdebug_2_0_3_5_2_5!xdebug_init_oparray+0x10e00 (01959270)]
0194847a 8b00 mov eax,[eax]
0194847c 8b0dec339601 mov ecx,[php_xdebug_2_0_3_5_2_5!zend_extension_entry+0x6dc (019633ec)]
01948482 83c408 add esp,0x8
01948485 8b5488fc mov edx,[eax+ecx*4-0x4]
01948489 8b4c2404 mov ecx,[esp+0x4]
0194848d 8b8280000000 mov eax,[edx+0x80]
01948493 c744817c00000000 mov dword ptr [ecx+eax*4+0x7c],0x0
0194849b c3 ret

so i think problem is in this code:

ZEND_DLEXPORT void xdebug_init_oparray(zend_op_array *op_array)
{
        TSRMLS_FETCH();
        op_array->reserved[XG(reserved_offset)] = 0;
}

maybe reserved_offset has some invalid values...
TagsNo tags attached.
Operating SystemWindows 2000/IIS
PHP Version5.2.6

Relationships

duplicate of 0000410 closed Apache crashes on Vista with xDebug installed 

Activities

derick

2008-07-04 09:34

administrator   ~0000860

Do you have a short reproducible script for this issue?

AlexanderLAW

2008-07-04 09:46

reporter   ~0000864

No, I don't. I encounter this exception while moodle usage, and it comes out on different pages. I don't think, that it's related to some specific code. It can dissappear after a page refresh and then raise again. Maybe it's the same as bug report 0000377.

Best regards,
Alexander

Issue History

Date Modified Username Field Change
2008-07-04 07:48 AlexanderLAW New Issue
2008-07-04 09:34 derick Note Added: 0000860
2008-07-04 09:34 derick Status new => feedback
2008-07-04 09:46 AlexanderLAW Note Added: 0000864
2009-11-27 17:05 derick Relationship added duplicate of 0000410
2009-11-27 17:05 derick Duplicate ID 0 => 410
2009-11-27 17:05 derick Status feedback => resolved
2009-11-27 17:05 derick Resolution open => duplicate
2009-11-27 17:05 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)