View Issue Details

IDProjectCategoryView StatusLast Update
0000394XdebugFeature/Change requestpublic2016-12-13 21:37
Reporterd_kelseyAssigned Toderick 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0000394: use the stderr stream in DBGp to route messages from php error handler to a debug client
DescriptionBased on a request from a user of PDT, the user wanted to redirect any php warnings to PDT (ie not display them on the web page).

This could be achieved if XDebug routed php error handler generated messages via the stderr stream rather than stdout stream.
TagsNo tags attached.
Operating System
PHP Version5.2.5

Relationships

has duplicate 0000004 resolvedderick Debug information only in client 

Activities

user996

2009-07-20 06:09

  ~0001000

sdsfdfdsfsddfdsf

derick

2016-12-13 21:37

administrator   ~0004053

This is now possible (since 2.3.x) by setting a breakpoint for the "Exception" Notice and Warning. This is described at https://derickrethans.nl/xdebug-2.3-debugging-improvements.html

Issue History

Date Modified Username Field Change
2008-08-06 08:06 d_kelsey New Issue
2008-08-06 09:18 derick Relationship added has duplicate 0000004
2009-07-20 06:09 user996 Note Added: 0001000
2016-12-13 21:37 derick Note Added: 0004053
2016-12-13 21:37 derick Status new => resolved
2016-12-13 21:37 derick Resolution open => no change required
2016-12-13 21:37 derick Assigned To => derick