View Issue Details

IDProjectCategoryView StatusLast Update
0000412XdebugInstallationpublic2008-12-20 19:53
ReporterMasterXAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0000412: make: *** [xdebug_code_coverage.lo] Error 1
DescriptionDear all

I have tried to install xdebug on my server but it has error when compile.

I use cc (GCC) 4.1.1 20070105 (Red Hat 4.1.1-52) and PHP 4.4.9.

I ran command: ./configure --enable-xdebug --with-php-config=/Thanh/php-4.4.9/scripts/php-config

After that I ran make but it shown me error:

/bin/sh /Thanh/xdebug-2.0.3/libtool --mode=compile gcc -I. -I/Thanh/xdebug-2.0.3 -DPHP_ATOM_INC -I/Thanh/xdebug-2.0.3/include -I/Thanh/xdebug-2.0.3/main -I/Thanh/xdebug-2.0.3 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -DHAVE_CONFIG_H -g -O0 -c /Thanh/xdebug-2.0.3/xdebug_code_coverage.c -o xdebug_code_coverage.lo
gcc -I. -I/Thanh/xdebug-2.0.3 -DPHP_ATOM_INC -I/Thanh/xdebug-2.0.3/include -I/Thanh/xdebug-2.0.3/main -I/Thanh/xdebug-2.0.3 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -DHAVE_CONFIG_H -g -O0 -c /Thanh/xdebug-2.0.3/xdebug_code_coverage.c -fPIC -DPIC -o xdebug_code_coverage.lo
/Thanh/xdebug-2.0.3/xdebug_code_coverage.c: In function 'xdebug_find_jump':
/Thanh/xdebug-2.0.3/xdebug_code_coverage.c:148: error: 'union <anonymous>' has no member named 'jmp_addr'
/Thanh/xdebug-2.0.3/xdebug_code_coverage.c: In function 'prefill_from_oparray':
/Thanh/xdebug-2.0.3/xdebug_code_coverage.c:233: warning: assignment makes pointer from integer without a cast
/Thanh/xdebug-2.0.3/xdebug_code_coverage.c: In function 'prefill_from_function_table':
/Thanh/xdebug-2.0.3/xdebug_code_coverage.c:272: warning: comparison between pointer and integer
/Thanh/xdebug-2.0.3/xdebug_code_coverage.c: In function 'xdebug_prefill_code_coverage':
/Thanh/xdebug-2.0.3/xdebug_code_coverage.c:312: warning: comparison between pointer and integer
make: *** [xdebug_code_coverage.lo] Error 1

Please help me to fix it.
TagsNo tags attached.
Operating SystemCentOS 5.2
PHP Version4.4-dev

Relationships

duplicate of 0000372 resolvedderick Cannot compile xdebug. make gives error 1. 

Activities

greinauer

2008-10-09 11:11

reporter   ~0000881

Same Bug under OS Debian 4.0

PHP Version 4.4.4-8 (necessary for GForge in Debian distribution)
phpize and php-config created by Debian php4-dev

MasterX

2008-10-15 10:08

reporter   ~0000889

Last edited: 2008-10-15 10:10

I has compiled php-4.4.9 from source. It has phpize and php-config from its source. I use it but it show me error.

OS is CentOS, an distribute of RHEL, how can I use Debian Package in this case?

Please guide me in details.

edited on: 2008-10-15 11:10

greinauer

2008-10-16 07:20

reporter   ~0000891

Debian Distribution 4.0 may be downloaded from www.debian.org.
Debian uses the the Synaptic Package Manager. By help of the manager you can download and install php4 and php4-dev. php4-dev includes phpize and php-config directly.

ashnazg

2008-10-29 19:18

reporter   ~0000894

Duplicate of already resolved 0000372, I think?

Issue History

Date Modified Username Field Change
2008-10-07 08:29 MasterX New Issue
2008-10-09 11:11 greinauer Note Added: 0000881
2008-10-15 10:08 MasterX Note Added: 0000889
2008-10-15 10:10 MasterX Note Edited: 0000889
2008-10-16 07:20 greinauer Note Added: 0000891
2008-10-29 19:18 ashnazg Note Added: 0000894
2008-12-20 19:53 derick Relationship added duplicate of 0000372
2008-12-20 19:53 derick Duplicate ID 0 => 372
2008-12-20 19:53 derick Status new => resolved
2008-12-20 19:53 derick Resolution open => duplicate
2008-12-20 19:53 derick Assigned To => derick