View Issue Details

IDProjectCategoryView StatusLast Update
0000429XdebugFeature/Change requestpublic2009-03-03 09:38
ReportereduardomarinhoAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000429: Dump is unreadable sometimes
DescriptionThis problem was already reported by 0000349 but it wasn't explained very clearly.

The case is that the output doesn't put a color on the font, so it will use the color set by CSS for the fonts.

If the site CSS sets the font color to white or something alike, the output becomes unreadable, because the table background of the dump is gray.

I see 2 simple solutions for this, the first one being my favourite:

1) Change the output so it forces that the dump output font is black:
<td bgcolor="#eeeeec" align="right" color="black">

2) Make the dump have a CSS class on the outer table:
<table class="xdebug-something">

TagsNo tags attached.
Operating System
PHP Version5.2.6

Activities

derick

2009-03-03 09:38

administrator   ~0000922

All <table strings have such a class already:

derick@kossu:~/dev/php/xdebug$ grep -r '<table' *c
xdebug.c: "
\n<font size='1'><table class='xdebug-error' dir='ltr' border='1' cellspacing='0' cellpadding='1'>\n",
xdebug.c: fprintf(XG(trace_file), "<table class='xdebug-trace' dir='ltr' border='1' cellspacing='0'>\n");
xdebug_superglobals.c: php_printf("<table class='xdebug-superglobals' dir='ltr' border='1' cellspacing='0'>\n");

Issue History

Date Modified Username Field Change
2009-02-20 10:58 eduardomarinho New Issue
2009-02-20 10:58 eduardomarinho PHP Version => 5.2.6
2009-02-20 10:58 eduardomarinho Xdebug Version => 2.0.3
2009-03-03 09:38 derick Note Added: 0000922
2009-03-03 09:38 derick Status new => resolved
2009-03-03 09:38 derick Resolution open => unable to reproduce
2009-03-03 09:38 derick Assigned To => derick