View Issue Details

IDProjectCategoryView StatusLast Update
0000433Xdebug(No Category)public2009-04-18 22:28
Reporterp2409Assigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000433: ./configure check of el_init: nested functions are disabled (Mac OS X 10.5)
DescriptionConfiguring xdebugclient was failing due to inability to compile the el_init nested functions - they were something like this
int main() {
int el;

int main() {
  el=el_init
}
}

./configure reported : error: "you have strange libedit"
Additional InformationThis was on a new Leopard install btw.

The fix was simple:
de-nest the main functions in the el_init tests ie. just have one main() {}

Everything worked after that.
TagsNo tags attached.
Operating System
PHP Version5.2.8

Activities

derick

2009-03-28 17:22

administrator   ~0000929

Can you show me the full output and the full config.log? I see indeed the nested function in configure, but it compiles and works just fine here:

checking whether to use libedit... yes
checking for tgetflag in -ltermcap... yes
checking for el_set in -ledit... yes
checking for H_SETSIZE... H_SETSIZE
checking for number of arguments to el_init... 4

p2409

2009-04-18 15:58

reporter   ~0000953

Servus Derick!

Sorry it's been a while to get back to you.
I have just completely redone the phpize/configure/make on my iMac and this time, I get no such nested functions error now.

It must have been an odd environment for configure: note that nested functions are not allowed in C++, but for C files they are fine in GNU. I'm guessing my environment was C++ compiling (maybe from earlier work in the day). So....no problem ok to close.

Thanks for xdebug by the way I reckon it's making thousands of people's lives easier. Vielen Dank!

Pete

derick

2009-04-18 22:28

administrator   ~0000955

Okay, closing then.

Issue History

Date Modified Username Field Change
2009-03-19 16:10 p2409 New Issue
2009-03-19 16:10 p2409 PHP Version => 5.2.8
2009-03-19 16:10 p2409 Xdebug Version => 2.0.3
2009-03-28 17:22 derick Note Added: 0000929
2009-03-28 17:22 derick Status new => feedback
2009-04-18 15:58 p2409 Note Added: 0000953
2009-04-18 22:28 derick Note Added: 0000955
2009-04-18 22:28 derick Status feedback => resolved
2009-04-18 22:28 derick Resolution open => unable to reproduce
2009-04-18 22:28 derick Assigned To => derick
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)