View Issue Details

IDProjectCategoryView StatusLast Update
0000436Xdebug(No Category)public2009-11-27 16:53
ReportershiroamadaAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityrandom
Status resolvedResolutionduplicate 
Product Version2.0.0dev 
Target VersionFixed in Version 
Summary0000436: XDebug crash with Apache 2.2 with PHP 5.2.9-1
DescriptionI have new installation of WAMP yesterday,
I'm using php_xdebug-2.0.4-5.2.8.dll with my WAMP, Apache 2.2, and PHP 5.2.9-1 in Windows Vista

When I add these to my php.ini:
[XDebug]
;; Only Zend OR (!) XDebug
zend_extension_ts="C:\wamp\bin\php_xdebug-2.0.4-5.2.8.dll"
xdebug.remote_enable=true
xdebug.remote_host=localhost
xdebug.remote_port=9000
xdebug.remote_handler=dbgp
xdebug.profiler_enable=1
xdebug.profiler_output_dir="C:\wamp\tmp"
xdebug.remote_log = "C:\wamp\tmp\log.log"


My apache randomly crash, this is my report:
[Sat Mar 28 10:07:20 2009] [notice] Parent: child process exited with status 255 -- Restarting.
[Sat Mar 28 10:07:21 2009] [notice] Apache/2.2.11 (Win32) PHP/5.2.9-1 configured -- resuming normal operations
[Sat Mar 28 10:07:21 2009] [notice] Server built: Dec 10 2008 00:10:06
[Sat Mar 28 10:07:21 2009] [notice] Parent: Created child process 7008
[Sat Mar 28 10:07:22 2009] [notice] Child 7008: Child process is running
[Sat Mar 28 10:07:22 2009] [notice] Child 7008: Acquired the start mutex.
[Sat Mar 28 10:07:22 2009] [notice] Child 7008: Starting 64 worker threads.
[Sat Mar 28 10:07:22 2009] [notice] Child 7008: Starting thread to listen on port 80.


But when i disable the code in php.ini restart the apache everything is ok right now. Not sure what is the problem. I am using Esclipse IDE.
TagsNo tags attached.
Operating SystemVista Business SP1
PHP Version5.2-dev

Relationships

duplicate of 0000410 closed Apache crashes on Vista with xDebug installed 

Activities

trueleader

2009-08-21 08:08

reporter   ~0001044

This Bug still exists
With Windows Vista all Versions of PHP crashes when XDebug is activated. I tried multiple versions of xdebug, but all crashes. Some time ago i created a mailing list entry: http://xdebug.org/archives/xdebug-general/1609.html -> no response until now.

I find multiple posts for the google search "child process exited with status 255 xdebug" and nobody knows a real solution. The crashes are realy annoying because sometimes they are so often, that a normal browsing isnĀ“t possible and xdebug must be shut down

nsteblay

2009-08-21 10:46

reporter   ~0001045

This is similar to http://bugs.xdebug.org/view.php?id=410

Issue History

Date Modified Username Field Change
2009-03-28 12:54 shiroamada New Issue
2009-03-28 12:54 shiroamada Operating System => Vista Business SP1
2009-03-28 12:54 shiroamada PHP Version => 5.2-dev
2009-03-28 12:54 shiroamada Xdebug Version => 2.0.4-dev
2009-08-21 08:08 trueleader Note Added: 0001044
2009-08-21 10:46 nsteblay Note Added: 0001045
2009-11-27 16:53 derick Relationship added duplicate of 0000410
2009-11-27 16:53 derick Duplicate ID 0 => 410
2009-11-27 16:53 derick Status new => resolved
2009-11-27 16:53 derick Resolution open => duplicate
2009-11-27 16:53 derick Assigned To => derick
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)