View Issue Details

IDProjectCategoryView StatusLast Update
0000437XdebugUsage problems (Wrong Results)public2009-07-05 20:50
Reporterdhanson358Assigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformLinuxOSCent OSOS Version5.1
Product Version2.0.0dev 
Target VersionFixed in Version 
Summary0000437: Simple assignment not found by code coverage
DescriptionWhen doing simple variable assignment in the constructor of a class, code coverage report shows code as uncovered.
Steps To ReproduceUsing a class like this:

class Foo {
 public $my_bar;
 public __construct($bar) {
  $this->my_bar = $bar;
 }
}

The code coverage tool will show the line
$this->my_bar = $bar;

as not being covered.
TagsNo tags attached.
Operating System
PHP Version5.1.6

Activities

derick

2009-04-18 22:29

administrator   ~0000956

You need to provide a code example.

derick

2009-07-05 20:50

administrator   ~0000976

Can't reproduce this and no feed back was provided.

Issue History

Date Modified Username Field Change
2009-04-16 18:49 dhanson358 New Issue
2009-04-16 18:49 dhanson358 PHP Version => 5.1.6
2009-04-16 18:49 dhanson358 Xdebug Version => 2.0.0
2009-04-18 22:29 derick Note Added: 0000956
2009-04-18 22:29 derick Status new => feedback
2009-07-05 20:50 derick Note Added: 0000976
2009-07-05 20:50 derick Status feedback => resolved
2009-07-05 20:50 derick Resolution open => unable to reproduce
2009-07-05 20:50 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)