View Issue Details

IDProjectCategoryView StatusLast Update
0000438XdebugUsage problems (Wrong Results)public2009-07-05 22:25
Reporterlaurin1Assigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.0.0dev 
Target VersionFixed in Version 
Summary0000438: xDebug Crashes PHP When Enabled
DescriptionIf I disable xDebug, it works fine. Only with debug enabled does this happen.

xdebug (2.04) (though, I have tried with numerous versions (2.03, 2.02, 2.01)

************************************
I get this over and over, and then eventually it crashes completely:

PHP has encountered an Access Violation at 00BD8693

************************************
In the Windows Application Event Log:

Log Name: Application
Source: Application Error
Date: 4/27/2009 6:43:17 PM
Event ID: 1000
Task Category: (100)
Level: Error
Keywords: Classic
User: N/A
Computer: KDAVIS.pridedallas.com
Description:
Faulting application w3wp.exe, version 7.0.6002.16670, time stamp 0x4983dae0, faulting module ntdll.dll, version 6.0.6002.16670, time stamp 0x4983ef11, exception code 0xc0000374, fault offset 0x000b04c4, process id 0x11b4, application start time 0x01c9c791b89c5595.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2009-04-27T23:43:17.000Z" />
    <EventRecordID>8938</EventRecordID>
    <Channel>Application</Channel>
    <Computer>KDAVIS.pridedallas.com</Computer>
    <Security />
  </System>
  <EventData>
    <Data>w3wp.exe</Data>
    <Data>7.0.6002.16670</Data>
    <Data>4983dae0</Data>
    <Data>ntdll.dll</Data>
    <Data>6.0.6002.16670</Data>
    <Data>4983ef11</Data>
    <Data>c0000374</Data>
    <Data>000b04c4</Data>
    <Data>11b4</Data>
    <Data>01c9c791b89c5595</Data>
  </EventData>
</Event>

Log Name: Application
Source: Windows Error Reporting
Date: 4/27/2009 6:43:56 PM
Event ID: 1001
Task Category: None
Level: Information
Keywords: Classic
User: N/A
Computer: KDAVIS.pridedallas.com
Description:
Fault bucket 1172393333, type 1
Event Name: APPCRASH
Response: None
Cab Id: 0

Problem signature:
P1: w3wp.exe
P2: 7.0.6002.16670
P3: 4983dae0
P4: StackHash_2061
P5: 6.0.6002.16670
P6: 4983ef11
P7: c0000374
P8: 000b04c4
P9:
P10:

Attached files:
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\Report0b3ca2a9\WER9937.tmp.version.txt
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\Report0b3ca2a9\WER9938.tmp.appcompat.txt
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\Report0b3ca2a9\WER9A03.tmp.hdmp
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\Report0b3ca2a9\WERA22F.tmp.mdmp

These files may be available here:
C:\ProgramData\Microsoft\Windows\WER\ReportArchive\Report197530f3
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Windows Error Reporting" />
    <EventID Qualifiers="0">1001</EventID>
    <Level>4</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2009-04-27T23:43:56.000Z" />
    <EventRecordID>8939</EventRecordID>
    <Channel>Application</Channel>
    <Computer>KDAVIS.pridedallas.com</Computer>
    <Security />
  </System>
  <EventData>
    <Data>1172393333</Data>
    <Data>1</Data>
    <Data>APPCRASH</Data>
    <Data>None</Data>
    <Data>0</Data>
    <Data>w3wp.exe</Data>
    <Data>7.0.6002.16670</Data>
    <Data>4983dae0</Data>
    <Data>StackHash_2061</Data>
    <Data>6.0.6002.16670</Data>
    <Data>4983ef11</Data>
    <Data>c0000374</Data>
    <Data>000b04c4</Data>
    <Data>
    </Data>
    <Data>
    </Data>
    <Data>
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\Report0b3ca2a9\WER9937.tmp.version.txt
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\Report0b3ca2a9\WER9938.tmp.appcompat.txt
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\Report0b3ca2a9\WER9A03.tmp.hdmp
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\Report0b3ca2a9\WERA22F.tmp.mdmp</Data>
    <Data>C:\ProgramData\Microsoft\Windows\WER\ReportArchive\Report197530f3</Data>
  </EventData>
</Event>
Additional InformationIIS 7
TagsNo tags attached.
Operating SystemWindows Vista Business Service Pack 2 (RC1)
PHP Version5.2.8

Relationships

duplicate of 0000410 closed Apache crashes on Vista with xDebug installed 

Activities

derick

2009-07-05 22:25

administrator   ~0000980

DUplicate of bug 0000410.

Issue History

Date Modified Username Field Change
2009-04-28 14:06 laurin1 New Issue
2009-04-28 14:06 laurin1 Operating System => Windows Vista Business Service Pack 2 (RC1)
2009-04-28 14:06 laurin1 PHP Version => 5.2.8
2009-04-28 14:06 laurin1 Xdebug Version => 2.0.4-dev
2009-07-05 22:25 derick Note Added: 0000980
2009-07-05 22:25 derick Relationship added duplicate of 0000410
2009-07-05 22:25 derick Duplicate ID 0 => 410
2009-07-05 22:25 derick Status new => resolved
2009-07-05 22:25 derick Resolution open => duplicate
2009-07-05 22:25 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)