View Issue Details

IDProjectCategoryView StatusLast Update
0000444XdebugUncategorizedpublic2009-11-27 16:53
ReporterangulionAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version2.0.0dev 
Target VersionFixed in Version 
Summary0000444: Xdebug unable to send source files containing %<numbers>
DescriptionDebuging while using Smarty template engine came up with the problem that xdebug seems to url-encode filenames. Smartys compiled templates are in the form:
%%82^823^823B39A1%%layout.tpl.php

Xdebug tries to open and send to the client a file by name:
MyTitle Warning: main(/srv/www/vhosts/myhost/htdocs/templates_c/%?^823^823B39A1%%layout.tpl.php): failed to open stream: No such file or directory in /srv/www/vhosts/myhost/htdocs/templates_c/%%82^823^823B39A1%%layout.tpl.ph:

Second % sign and number 82 gets converted to some garbage.
When opening files, names should not be passed through usefulstuff.c:xdebug_raw_url_encode, called from xdebug_handler_dbgp.c:xdebug_path_from_url, called from return_file_source (?).

PHP 5.2.9, Xdebug 2.0.4, host is Linux (Opensuse 11.1)
TagsNo tags attached.
Operating SystemLinux
PHP Version5.2.8

Activities

angulion

2009-06-06 22:09

reporter   ~0000964

It seems the error stems from XDC client on windows already asking for invalid name? (version 1.0beta3)

derick

2009-07-05 19:43

administrator   ~0000974

So this sounds like a bug in XDC?

derick

2009-10-17 17:51

administrator   ~0001101

Reminder sent to: angulion

So this sounds like a bug in XDC?

Issue History

Date Modified Username Field Change
2009-06-06 22:03 angulion New Issue
2009-06-06 22:03 angulion Operating System => Linux
2009-06-06 22:03 angulion PHP Version => 5.2.8
2009-06-06 22:03 angulion Xdebug Version => 2.0.4-dev
2009-06-06 22:09 angulion Note Added: 0000964
2009-07-05 19:43 derick Note Added: 0000974
2009-07-05 19:43 derick Status new => feedback
2009-10-17 17:51 derick Note Added: 0001101
2009-11-27 16:53 derick Status feedback => resolved
2009-11-27 16:53 derick Resolution open => unable to reproduce
2009-11-27 16:53 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2020-03-12 16:35 derick Category Usage problems (Wrong Results) => Variable Display
2020-03-12 16:38 derick Category Variable Display => Uncategorized