View Issue Details

IDProjectCategoryView StatusLast Update
0000452XdebugInstallationpublic2009-11-27 16:54
ReporterWebCMAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.0.0dev 
Target VersionFixed in Version 
Summary0000452: PHP 5.3 TS VC9 crashes when Xdebug is enabled
DescriptionI updated PHP to 5.3 thread-safe VC9 version and downloaded the latest Xdebug 2.0.5 for 5.3 VC9 (32 bit). As mentioned in the documentation, I added zend_extension= instead of zend_extension_ts=

PHP crashes when I try to run ANY script. Apache version: Apache 2.2.4
Additional InformationHere is my PHP.INI file (zend_extension is marked): http://pastebin.com/m4778803f

I tried older version - they even don't start.
TagsNo tags attached.
Operating SystemWindows XP Home SP3
PHP Version5.3.0

Relationships

duplicate of 0000410 closed Apache crashes on Vista with xDebug installed 

Activities

derick

2009-07-16 22:18

administrator   ~0000992

Where did you get Apache from? If you got it from apache.org you need the VC6 binaries of PHP and Xdebug.

Soul--Reaver

2009-07-19 21:36

reporter   ~0000999

I'm having this problem aswell.

I'm using the apache 2.2.11a binaries from apachelounge.com
I'm using the same php version as above

When i start php.exe -v i see that xdebug is loaded properly. Also when i use the same method to retrieve the phpinfo() information everything works OK

But when i load php as a module in apache, everything works untill i request the first .php page and then tells me the apache program crashed and what was the faulting dll file. The faulting dll file is php_xdebug.dll according to windows.

Hope this helps

ericp

2009-07-30 07:56

reporter   ~0001007

I've verified this problem with the cli version of php:

* php.exe from
http://windows.php.net/downloads/releases/php-5.3.0-Win32-VC9-x86.zip
(I wish they put a "-ts-" in the filename so it's easier to
distinguish from "-nts-").

* http://xdebug.org/files/php_xdebug-2.0.5-5.3-vc9.dll

Incidentally, in the php.ini file I need to have
zend_extension point to the xdebug DLL --
"zend_extension_ts" does nothing

PHP can safely load xdebug, but at the start of a debugging
session PHP crashes.

This is on Vista.

Debugging works with both ts and nts for VC6, and nts for VC9/x86.
I haven't had a chance to test the x64 builds yet.

eis_os

2009-07-30 13:50

reporter   ~0001008

php_xdebug-2.0.5-5.3-vc9.dll is really version 2.1.0dev (check the attached version info)
Compiled from 2.0.5 source the dll file seems to work ok.

ericp

2009-07-30 18:49

reporter   ~0001009

eis_os: where's the attached version info? And how did you get it?

eis_os

2009-07-31 08:59

reporter   ~0001010

You can right click the dll and see the file version, when starting php in cli mode it shows 2.1.0-dev or the brute force variant: open the dll in some editor and look for API2009, the next string is the versions number.

As noted, I compiled a vc9 thread safety version from source because I had the same crash and currently I don't seem to have a problem with my compiled version. So php_xdebug-2.0.5-5.3-vc9.dll on the server is currently version 2.1.0-dev (TS,VC9) and it will crash php5.3. Derick has to upload the right version.

derick

2009-08-01 16:55

administrator   ~0001013

Please try the php_xdebug-2.1 versions from http://files.derickrethans.nl/xdebug-2.1-all.zip — they should have a fix. Make sure you use the correct VC version with your version of apache. The apache from apache.org requires VC6, the apache from apachefriends requires VC9 builds of PHP and Xdebug.

Soul--Reaver

2009-08-01 18:09

reporter   ~0001019

php_xdebug-2.1dev-5.3-vc9.dll - works for me :D

Soul--Reaver

2009-08-01 18:35

reporter   ~0001020

Last edited: 2009-08-01 18:37

hmmm after some testing there are still some problems.

the dll loads and shows properly on the phpinfo page.

Also when i create a page which forces an error xdebug properly shows the error properly and in xdebug style.

But every now and then apache crashes and shows php_xdebug.dll as the source of the crash. This happens especially often when loading the first page of phppgadmin and phpmyadmin. The error occurs with those scripts about 95% of the times i tried to load it.

Maybe this helps: szAppName : httpd.exe szAppVer : 2.2.11.0 szModName : php_xdebug.dll
szModVer : 2.1.0.0 offset : 00005ef6

Issue History

Date Modified Username Field Change
2009-07-12 23:08 WebCM New Issue
2009-07-12 23:08 WebCM Operating System => Windows XP Home SP3
2009-07-12 23:08 WebCM PHP Version => 5.3.0
2009-07-12 23:08 WebCM Xdebug Version => 2.0.5
2009-07-16 22:18 derick Note Added: 0000992
2009-07-16 22:18 derick Status new => feedback
2009-07-19 21:36 Soul--Reaver Note Added: 0000999
2009-07-30 07:56 ericp Note Added: 0001007
2009-07-30 13:50 eis_os Note Added: 0001008
2009-07-30 18:49 ericp Note Added: 0001009
2009-07-31 08:59 eis_os Note Added: 0001010
2009-08-01 16:55 derick Note Added: 0001013
2009-08-01 18:09 Soul--Reaver Note Added: 0001019
2009-08-01 18:35 Soul--Reaver Note Added: 0001020
2009-08-01 18:37 Soul--Reaver Note Edited: 0001020
2009-11-27 16:54 derick Relationship added duplicate of 0000410
2009-11-27 16:54 derick Duplicate ID 0 => 410
2009-11-27 16:54 derick Status feedback => resolved
2009-11-27 16:54 derick Resolution open => duplicate
2009-11-27 16:54 derick Assigned To => derick