View Issue Details

IDProjectCategoryView StatusLast Update
0000454Xdebug(No Category)public2009-11-27 16:55
ReportertrekkerAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.0.0dev 
Target VersionFixed in Version 
Summary0000454: Official XDebug binary crash with PHP 5.3.0
DescriptionWhile running simple php script I always end with an Access Violation inside php_xdebug-2.0.5-5.3-vc9.dll

<?

  phpinfo();

?>

It seems that the cause is using xdebug_init_oparray: XG(reserved_offset) value is negative. It seems some kind of memory corruption inside xdebug ?
Additional Informationphp.ini
zend_extension=.\ext\php_xdebug-2.0.5-5.3-vc9.dll

E:\php5>php.exe -v
PHP 5.3.0 (cli) (built: Jun 29 2009 21:55:01)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2009 Zend Technologies
    with Xdebug v2.1.0-dev, Copyright (c) 2002-2008, by Derick Rethans
TagsNo tags attached.
Operating System
PHP Version5.3.0

Relationships

duplicate of 0000410 closed Apache crashes on Vista with xDebug installed 

Activities

soki

2009-07-17 18:55

reporter   ~0000998

I'm having the same issue under IIS (FastCGI).
This is the report from Eventviewer:

Fehlerbucket 1370980847, Typ 1
Ereignisname: APPCRASH
Antwort: Keine
Cab-ID: 0

Problemsignatur:
P1: php-cgi.exe
P2: 5.3.0.0
P3: 4a492a25
P4: php_xdebug-2.0.5-5.3-vc9.dll
P5: 2.1.0.0
P6: 4a4c79bc
P7: c0000005
P8: 00005e59
P9:
P10:

Issue History

Date Modified Username Field Change
2009-07-17 14:08 trekker New Issue
2009-07-17 14:08 trekker PHP Version => 5.3.0
2009-07-17 14:08 trekker Xdebug Version => 2.1.0-dev
2009-07-17 18:55 soki Note Added: 0000998
2009-11-27 16:55 derick Relationship added duplicate of 0000410
2009-11-27 16:55 derick Duplicate ID 0 => 410
2009-11-27 16:55 derick Status new => resolved
2009-11-27 16:55 derick Resolution open => duplicate
2009-11-27 16:55 derick Assigned To => derick
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)