View Issue Details

IDProjectCategoryView StatusLast Update
0000456XdebugDocumentationpublic2009-08-01 17:26
ReporterdenisoAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0000456: Xdebug 2.0.5 do not run on PHP 5.2.9
DescriptionIn documentation I've found info that xdebug 2.0.5 should work with PHP 5.2.9

5.2.x 20041225 20060613 220060519 2.0.5

But after instalation, a get this error:
Xdebug requires Zend Engine API version 220090115.
The Zend Engine API version 220060519 which is installed, is outdated.

Is that bug of documentation? Or may be I dont understand something?
Additional InformationApache 2.
TagsNo tags attached.
Operating SystemLinux Mandriva 2009.1
PHP Version5.2.9

Activities

derick

2009-08-01 17:25

administrator   ~0001016

You just need to make sure to compile Xdebug against the headers that belong to your PHP version. It works fine with 5.2.9 once you recompile.

Issue History

Date Modified Username Field Change
2009-07-20 18:37 deniso New Issue
2009-07-20 18:37 deniso Operating System => Linux Mandriva 2009.1
2009-07-20 18:37 deniso PHP Version => 5.2.9
2009-07-20 18:37 deniso Xdebug Version => 2.0.5
2009-08-01 17:25 derick Note Added: 0001016
2009-08-01 17:25 derick Status new => resolved
2009-08-01 17:25 derick Resolution open => no change required
2009-08-01 17:25 derick Assigned To => derick