View Issue Details

IDProjectCategoryView StatusLast Update
0000460XdebugUsage problems (Wrong Results)public2009-08-06 10:39
ReporterapinsteinAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0000460: GUI clients always show "uninitialized" for local-scope variables.
DescriptionI think this might be related to http://bugs.xdebug.org/view.php?id=376 but I don't see how to comment on a closed ticket.

I have tried MacGDP and Komodo IDE as clients and both report "uninitialized" for all local vars. Object vars seem to work.

GDB is effectively useless due to this.
TagsNo tags attached.
Operating Systemmac 10.5.5
PHP Version5.3.0

Relationships

duplicate of 0000376 closed Fail context for local variable 

Activities

derick

2009-08-06 10:39

administrator   ~0001027

Duplicate of 0000376 — My mistake, this is only in HEAD (2.1-dev) and not in 2.0.5.

Issue History

Date Modified Username Field Change
2009-08-05 19:08 apinstein New Issue
2009-08-05 19:08 apinstein Operating System => mac 10.5.5
2009-08-05 19:08 apinstein PHP Version => 5.3.0
2009-08-05 19:08 apinstein Xdebug Version => 2.0.5
2009-08-06 10:39 derick Note Added: 0001027
2009-08-06 10:39 derick Relationship added duplicate of 0000376
2009-08-06 10:39 derick Duplicate ID 0 => 376
2009-08-06 10:39 derick Status new => resolved
2009-08-06 10:39 derick Resolution open => duplicate
2009-08-06 10:39 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)