View Issue Details

IDProjectCategoryView StatusLast Update
0000462XdebugUsage problems (Wrong Results)public2009-12-27 14:30
ReporterhusenAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000462: segmentation fault upon activating pecl newt extension
DescriptionI am receiving segmentation fault error when running command phing to run unit tests and produce coverage report. If I disable newt extension, then not any error. Not sure whether this is correct place to report bug.

test$ phing
Buildfile: /test/build.xml

fads4coreadmin > unittest:

   [delete] Deleting directory /tests/unittests/reports
    [mkdir] Created dir: /tests/unittests/reports/coverage
[coverage-setup] Setting up coverage database for 6 files
[coverage-report] Transforming coverage report

BUILD FINISHED

Total time: 2.2910 seconds

Segmentation fault
TagsNo tags attached.
Operating Systemkubuntu
PHP Version5.3.0

Activities

derick

2009-08-06 10:42

administrator   ~0001029

In order to know, I would need at least a GDB backtrace, and even better would be a short reproducing case to go with this. I don't have the time to debug phing.

husen

2009-08-06 11:54

reporter   ~0001031

is it something below you are looking for? Sorry to say but I'm not quite good with *unix:)

$ bashdb /usr/local/bin/phing
Bourne-Again Shell Debugger, release bash-3.1-0.08
Copyright 2002, 2003, 2004, 2006, 2007 Rocky Bernstein
This is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.

(/usr/local/bin/phing:9):
9: PHP_COMMAND="/usr/local/bin/php"
bashdb<0> next
(/usr/local/bin/phing:10):
10: export PHP_COMMAND
bashdb<1> next
(/usr/local/bin/phing:22):
22: $PHP_COMMAND -d html_errors=off -qC /usr/local/lib/php/phing.php -logger phing.listener.AnsiColorLogger "$@"
bashdb<2> next
Buildfile: /home/husen/project/fads/test/build.xml

fads4coreadmin > unittest:

   [delete] Deleting directory /tests/unittests/reports
    [mkdir] Created dir: /tests/unittests/reports/coverage
[coverage-setup] Setting up coverage database for 6 files
[coverage-report] Transforming coverage report

BUILD FINISHED

Total time: 2.2016 seconds

/usr/local/bin/phing: line 22: 26833 Segmentation fault $PHP_COMMAND -d html_errors=off -qC /usr/local/lib/php/phing.php -logger phing.listener.AnsiColorLogger "$@"
(/usr/bin/bashdb:288):
288:
bashdb<3> bt
->0 in file `/usr/bin/bashdb' at line 288
##1 main() called from file `/usr/bin/bashdb' at line 0
bashdb<4> q

derick

2009-08-06 12:13

administrator   ~0001032

No, I need a gdb backtrace. See: http://bugs.php.net/bugs-generating-backtrace.php (probably the bit for "command line" under "If you can't get a core file:"

derick

2009-10-17 17:41

administrator   ~0001100

Reminder sent to: husen

No, I need a gdb backtrace. See: http://bugs.php.net/bugs-generating-backtrace.php [^] (probably the bit for "command line" under "If you can't get a core file:"

derick

2009-12-27 14:30

administrator   ~0001209

Requested feedback not provided.

Issue History

Date Modified Username Field Change
2009-08-06 10:20 husen New Issue
2009-08-06 10:20 husen Operating System => kubuntu
2009-08-06 10:20 husen PHP Version => 5.3.0
2009-08-06 10:20 husen Xdebug Version => 2.0.5
2009-08-06 10:42 derick Note Added: 0001029
2009-08-06 10:42 derick Status new => feedback
2009-08-06 11:54 husen Note Added: 0001031
2009-08-06 12:13 derick Note Added: 0001032
2009-10-17 17:41 derick Note Added: 0001100
2009-12-27 14:30 derick Note Added: 0001209
2009-12-27 14:30 derick Status feedback => resolved
2009-12-27 14:30 derick Resolution open => unable to reproduce
2009-12-27 14:30 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)