View Issue Details

IDProjectCategoryView StatusLast Update
0000464XdebugFeature/Change requestpublic2009-10-24 18:19
ReporterkapouerAssigned Toderick 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionno change required 
Product Version2.0.0dev 
Target VersionFixed in Version 
Summary0000464: Externalize html template strings
DescriptionThe html strings used as arguments in the printf calls should be externalized in a document, and that document's path should be passed as parameter in the xdebug.ini.
That would be so great... on many websites i develop the xdebug output is unreadable, due to special page layouts. And because of the xdebug html output, reading the source page is quite painful.
A smaller feature would be a configuration parameter in xdebug.ini, that would switch output between plain text (with line feeds) or html.
Thanks for your attention.
TagsNo tags attached.
Operating System
PHP Version5.3.0

Activities

derick

2009-10-24 18:19

administrator   ~0001114

All Xdebug output has CSS style classes, which should be more than enough to customize the layout. The turning off of HTML-based errors is controlled by PHP's html_errors setting.

Issue History

Date Modified Username Field Change
2009-08-06 12:14 kapouer New Issue
2009-08-06 12:14 kapouer PHP Version => 5.3.0
2009-08-06 12:14 kapouer Xdebug Version => 2.0.5
2009-10-24 18:19 derick Note Added: 0001114
2009-10-24 18:19 derick Status new => resolved
2009-10-24 18:19 derick Resolution open => no change required
2009-10-24 18:19 derick Assigned To => derick