View Issue Details

IDProjectCategoryView StatusLast Update
0000047XdebugUsage problems (Wrong Results)public2005-12-30 17:00
ReportersergioAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000047: Profile data not dumped on file when profiling is called from PHP script
DescriptionIf profiling is called from script with

  xdebug_start_profiling('/path/to/some/dir/'.$variableFilename)

profiling data are displayed to screen but no written to file.
The file as been created but it contain only 2 lines

  Start of function profiler
  End of function profiler

If the profiling is started from php.ini all is working fine (no HTML output, data written to file)
Additional Informationthis is the code used

<?php
//begin of profiling
xdebug_start_profiling('/tmp/xdebug/profile_'.time().'.txt');

// code here

// end and display of profiling
$level = 4; // this is the format of the report usefull value 1, 4, 5
echo 'script: ',__FILE__, '@',date("d-m-Y H:i", time()), 'profile level ',$level;
xdebug_dump_function_profile($level);
xdebug_stop_profiling();
?>
TagsNo tags attached.
Operating SystemRed Hat 7.3, Mac OS X 10.3.2
PHP Version4.3.10

Activities

sergio

2004-02-27 13:22

reporter   ~0000101

Sorry, this is reported in bug 000021 and solved. Readed after posting... :-}

sergio

2004-02-27 15:08

reporter   ~0000102

I'm posting again...
I can replicate the behavior also omitting the xdebug_dump_function_profile() from the code.
No profile data are written to file.
It's probably my fault but where?

derick

2004-02-27 21:05

administrator   ~0000103

You should remove the xdebug_stop_profiling() function as it will clean up all the data before the profiling information is written to the file. (You might also have to remove the xdebug_dump_function_profile() function).

sergio

2004-03-01 10:06

reporter   ~0000105

Last edited: 2004-03-01 10:24

It is still dumping anything but

Start of function profiler
End of function profiler

to file.

The code i'm testing is the following

<?php
xdebug_start_profiling('/dati/home/aghemo/oracle.showroom.loc/xdebug/'.time().'.txt');

echo date("d-m-Y H:i", time());

phpinfo();
?>

If could be related I cannot guess way to start xdebug profiling from httpd.conf nor .htaccess; only php.ini auto start profiling works

edited on: 2004-03-01 10:24

derick

2005-09-23 09:37

administrator   ~0000297

Does this still happen with the latest CVS version (2.0.0beta3-dev)?

derick

2005-12-30 17:00

administrator   ~0000323

I got no feedback, so I'm closing this report as I can not duplicate it either.

Issue History

Date Modified Username Field Change
2004-02-27 13:19 sergio New Issue
2004-02-27 13:22 sergio Note Added: 0000101
2004-02-27 15:08 sergio Note Added: 0000102
2004-02-27 21:05 derick Note Added: 0000103
2004-02-27 21:05 derick Status new => feedback
2004-03-01 10:06 sergio Note Added: 0000105
2004-03-01 10:24 sergio Note Edited: 0000105
2005-09-23 09:37 derick PHP Version 4.3.2 => 4.3.10
2005-09-23 09:37 derick Note Added: 0000297
2005-12-30 17:00 derick Status feedback => resolved
2005-12-30 17:00 derick Resolution open => unable to reproduce
2005-12-30 17:00 derick Assigned To => derick
2005-12-30 17:00 derick Note Added: 0000323
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)