View Issue Details

IDProjectCategoryView StatusLast Update
0000478XdebugUsage problems (Wrong Results)public2009-12-29 15:18
ReportersmerrillAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.0.0dev 
Target VersionFixed in Version 
Summary0000478: XDebug 2.0.x can't use %R in xdebug.profiler_output_name if register_long_arrays is off
DescriptionPHP 5.2.10
XDebug 2.0.5 compiled from pecl
CentOS 5.3

%R wouldn't work as a parameter in xdebug.profiler_output_name unless register_long_arrays is turned off. This is the default in the php packages from the remi repo on CentOS. It might be worth a note in the XDebug documentation.
TagsNo tags attached.
Operating SystemCentOS 5.3
PHP Version5.2.10

Relationships

duplicate of 0000324 closed xdebug_dump_superglobals() only dumps superglobals that were accessed before 
has duplicate 0000312 resolvedderick profiler_output_name: %R and %H only work with register_globals=On 

Activities

galiyosha

2009-11-16 14:49

reporter   ~0001130

I confirm this behaviour (both Linux with PHP 5.2.10/Xdebug 2.0.5 and Solaris 10 5/09 with PHP 5.2.4/Xdebug 2.0.5).

With a php.ini like this, %R does not work:

register_long_arrays=Off
register_globals=Off

zend_extension=/usr/lib/php/xdebug.so
xdebug.profiler_enable=On
xdebug.profiler_output_dir=/tmp/xdebug
xdebug.profiler_output_name=trace.%R

while with a php.ini like this, it does:

register_long_arrays=On
register_globals=Off

zend_extension=/usr/lib/php/xdebug.so
xdebug.profiler_enable=On
xdebug.profiler_output_dir=/tmp/xdebug
xdebug.profiler_output_name=trace.%R

If register_globals is On, register_long_arrays can be Off, so this issue may be related to issue 0000312. So, for example, with a php.ini like this, %R does work:

register_long_arrays=Off
register_globals=On

zend_extension=/usr/lib/php/xdebug.so
xdebug.profiler_enable=On
xdebug.profiler_output_dir=/tmp/xdebug
xdebug.profiler_output_name=trace.%R

One more tricky thing is that if xdebug.profiler_output_name is set to %R only (no prefix, no suffix), it sometimes works even with register_long_arrays and register_globals set to Off...

derick

2009-12-29 10:19

administrator   ~0001217

Could you please try this with Xdebug from SVN (http://xdebug.org/docs/install#source)? I can not reproduce this at all.

derick

2009-12-29 15:18

administrator   ~0001227

Similar to 324 that I can also not reproduce. I *did* commit a possible fix for it though.

Issue History

Date Modified Username Field Change
2009-10-24 23:51 smerrill New Issue
2009-10-24 23:51 smerrill Operating System => CentOS 5.3
2009-10-24 23:51 smerrill PHP Version => 5.2.10
2009-10-24 23:51 smerrill Xdebug Version => 2.0.5
2009-11-16 14:49 galiyosha Note Added: 0001130
2009-12-29 10:19 derick Note Added: 0001217
2009-12-29 10:19 derick Status new => feedback
2009-12-29 10:20 derick Relationship added has duplicate 0000312
2009-12-29 15:18 derick Note Added: 0001227
2009-12-29 15:18 derick Relationship added duplicate of 0000324
2009-12-29 15:18 derick Duplicate ID 0 => 324
2009-12-29 15:18 derick Status feedback => resolved
2009-12-29 15:18 derick Resolution open => duplicate
2009-12-29 15:18 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)