View Issue Details

IDProjectCategoryView StatusLast Update
0000489XdebugFeature/Change requestpublic2011-08-20 08:14
ReportertoddwAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.0.0dev 
Target VersionFixed in Version 
Summary0000489: profiling cachegrind output: add the filename references for called functions "cfl="
DescriptionAt present it is difficult (impossible?) to tell explicitly which function has been called by the "cfn=" lines, as there is no reference file "cfl=" given in the cachegrind files.

Example, given file1.php:

<?php
require "file2.php";
function func1() {
    echo "This is func 1\n";
    func2();
}
func1();
?>

and file2.php as:

<?php
function func2() {
    echo "This is func 2\n";
}
?>



The profiler output from running "file1.php" is:

version: 0.9.6
cmd: /srv/www/htdocs/php/xdebug/file1.php
part: 1

events: Time

fl=/srv/www/htdocs/php/xdebug/file2.php
fn=require::/srv/www/htdocs/php/xdebug/file2.php
1 2

fl=/srv/www/htdocs/php/xdebug/file2.php
fn=func2
9 0

fl=/srv/www/htdocs/php/xdebug/file1.php
fn=func1
12 44
cfn=func2
calls=1 0 0
9 0

fl=/srv/www/htdocs/php/xdebug/file1.php
fn={main}

summary: 193

0 145
cfn=require::/srv/www/htdocs/php/xdebug/file2.php
calls=1 0 0
5 2
cfn=func1
calls=1 0 0
12 45



According to the valgrind docs:
http://valgrind.org/docs/manual/cl-format.html

if a "cfl=" is not specified, it defaults to the current file "fl=", which would give the indication that "cfn=func2" is thus defined in file1.php (which is incorrect).

Adding the line:
    "cfl=/srv/www/htdocs/php/xdebug/file2.php"
before the "cfn=" would fix this ambiguous entry.
TagsNo tags attached.
Operating System
PHP Version5.3.0

Relationships

duplicate of 0000639 closedderick Xdebug profiling: output not correct - missing 'cfl=' 

Activities

toddw

2011-08-19 20:19

reporter   ~0001790

This is a duplicate of http://bugs.xdebug.org/view.php?id=639, which has since been fixed.

derick

2011-08-20 08:14

administrator   ~0001791

Thanks Todd. Marking this one as duplicate then!

Issue History

Date Modified Username Field Change
2009-11-20 02:51 toddw New Issue
2009-11-20 02:51 toddw PHP Version => 5.3.0
2009-11-20 02:51 toddw Xdebug Version => 2.0.5
2011-08-19 20:19 toddw Note Added: 0001790
2011-08-20 08:14 derick Note Added: 0001791
2011-08-20 08:14 derick Relationship added duplicate of 0000639
2011-08-20 08:14 derick Status new => resolved
2011-08-20 08:14 derick Resolution open => duplicate
2011-08-20 08:14 derick Assigned To => derick