View Issue Details

IDProjectCategoryView StatusLast Update
0000506XdebugInstallationpublic2010-01-02 22:54
Reporterfriendly12345Assigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version2.0.0dev 
Target VersionFixed in Version 
Summary0000506: Sources fail to compile on windows using VCx
Descriptionxdebug_com.obj : error LNK2005: _inet_aton already defined in inet.obj
libiconv_a.lib(iconv1.obj) : MSIL .netmodule or module compiled with /GL found;
restarting link with /LTCG; add /LTCG to the link command line to improve linker
 performance
xdebug_com.obj : error LNK2005: _inet_aton already defined in inet.obj
   Creating library Release_TS\php5ts.lib and object Release_TS\php5ts.exp
Release_TS\php5ts.dll : fatal error LNK1169: one or more multiply defined symbol
s found
NMAKE : fatal error U1077: '"C:\Program Files\Microsoft Visual Studio 9.0\VC\Bin
\cl.exe"' : return code '0x2'
Stop.
TagsNo tags attached.
Operating System
PHP Version5.3.0

Activities

derick

2010-01-02 22:54

administrator   ~0001243

This works for me, and I am not going to support Windows build systems (because I know nothing about it really).

Issue History

Date Modified Username Field Change
2010-01-01 06:46 friendly12345 New Issue
2010-01-01 06:46 friendly12345 PHP Version => 5.3.0
2010-01-01 06:46 friendly12345 Xdebug Version => 2.1.0-dev
2010-01-02 22:54 derick Note Added: 0001243
2010-01-02 22:54 derick Status new => resolved
2010-01-02 22:54 derick Resolution open => unable to reproduce
2010-01-02 22:54 derick Assigned To => derick