View Issue Details

IDProjectCategoryView StatusLast Update
0000510XdebugInstallationpublic2010-02-17 01:01
ReportermrzhaoAssigned Toderick 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000510: xdebug installation test
DescriptionI installed xdebug on remote linux server by compiling the source file.
I installed it without errors. and i could see "Zend Engine v2.2.0, Copyright (c) 1998-2009 Zend Technologies with Xdebug v2.1.0beta1" by using phpinfo() function.

then i run the test.php file from the server shell by using "php -e test.php"
<?php
echo ("1234567890");
 xdebug_break();
echo ("abcdefghijklmn");
?>
then, i got the following error message:

X-Powered-By: PHP/5.2.11
Content-type: text/html
1234567890

Fatal error: Call to undefined function xdebug_break() in /home2/username/public_html/debug/test.php on line 3


I opened this file in the IE and firefox windows,but i could see "1234567890abcdefghijklmn" in the page without error message.

could i test xdebug by this way?
TagsNo tags attached.
Operating System
PHP Version5.2.10

Activities

derick

2010-01-05 12:04

administrator   ~0001256

It's very likely that you have two different php.ini files. Try to find out which one the shell version uses with:

php -i | grep "Configuration File"

derick

2010-02-17 01:01

administrator   ~0001351

NO feedback provided, and likely a user error.

Issue History

Date Modified Username Field Change
2010-01-05 03:52 mrzhao New Issue
2010-01-05 03:52 mrzhao PHP Version => 5.2.10
2010-01-05 03:52 mrzhao Xdebug Version => 2.0.5
2010-01-05 12:04 derick Note Added: 0001256
2010-01-05 12:04 derick Status new => feedback
2010-02-17 01:01 derick Note Added: 0001351
2010-02-17 01:01 derick Status feedback => resolved
2010-02-17 01:01 derick Resolution open => unable to reproduce
2010-02-17 01:01 derick Assigned To => derick