View Issue Details

IDProjectCategoryView StatusLast Update
0000052XdebugUsage problems (Wrong Results)public2004-10-12 15:50
ReporteriansymAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000052: memory leak with xdebug.auto_profile = 1 in pnp.ini
DescriptionWhen setting
    xdebug.auto_profile = 1
in the php.ini file, it appears that xdebug leaks memory. I notice my memory meter on gkrellm shooting up with each script usage and eventually it dumps over into swap until all memory is used up.

I currently have xdebug 1.3.1dev installed (using Gentoo/Linux) running on Apache 2.0.48 using php 4.3.4.

Turning off xdebug.auto_profile seems to alleviate the leak problem.

my xdebug files are being written to my /tmp directory.
TagsNo tags attached.
Operating SystemGentoo GNU/Linux
PHP Version4.3.4

Activities

derick

2004-08-23 08:16

administrator   ~0000183

Is this still a problem with the latest versions of both PHP and Xdebug?

derick

2004-09-15 08:35

administrator   ~0000186

Reminder sent to iansym

 Is this still a problem with the latest versions of both PHP and Xdebug?

derick

2004-10-12 15:50

administrator   ~0000202

No feedback

Issue History

Date Modified Username Field Change
2004-03-22 19:49 iansym New Issue
2004-08-23 08:16 derick Xdebug Version 1.3-dev => 1.2.0
2004-08-23 08:16 derick Note Added: 0000183
2004-08-23 08:16 derick Status new => feedback
2004-09-15 08:35 derick Note Added: 0000186
2004-10-12 15:50 derick Status feedback => resolved
2004-10-12 15:50 derick Resolution open => unable to reproduce
2004-10-12 15:50 derick Assigned To => derick
2004-10-12 15:50 derick Note Added: 0000202
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)