View Issue Details

IDProjectCategoryView StatusLast Update
0000520XdebugUsage problems (Wrong Results)public2010-02-03 10:43
ReporterottoAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version2.0.0dev 
Target VersionFixed in Version 
Summary0000520: NetBeans crashes at end of session
DescriptionI'm running NetBeans 6.8. And I'm trying to debug a drupal-project.

When I stop at a break point, expand and view the contents of some variables (Arrays) and then continue the execution netbeans freaks out and starts popping up an infinite amount of socket exception windows.
Additional InformationIn the netbeans log I get messages like these: http://pastebin.com/m3fe45e3f (the last one is repeated many times)
I've put the xdebug remote_log here: http://www.mediafire.com/?wnttd5tz2yf
TagsNo tags attached.
Operating SystemOS X 10.6.2
PHP Version5.3.0

Relationships

has duplicate 0000530 resolvedderick Socket Exception occoured Error with php 5.3.1+NB 6.8+xdebug 2.0.5 on opensuse 11.1 64bit 

Activities

derick

2010-01-11 22:39

administrator   ~0001273

Hmm, this looks like netbeans is doing something strange. I am not a netbeans developer so I can't help you with this.

otto

2010-01-11 22:49

reporter   ~0001275

But it's working fine with an older xdebug snapshots (middle of october). Should I still check this with the netbeans devs?

derick

2010-01-11 23:04

administrator   ~0001276

I don't know what that error could be, it could be that PHP/Xdebug crashes but you didn't mention anything like that. If that's the case, please provide a backtrace. See the following URL on how to do that:
http://bugs.php.net/bugs-generating-backtrace.php

otto

2010-01-11 23:12

reporter   ~0001277

Sorry, but there is no sign of php crashing. When I have the time I will try to figure out from which revision this behaviour starts.

derick

2010-01-11 23:24

administrator   ~0001279

If you can, please provide a *short* reproducable script, and a remote_log that contains only communications for a single debugging session. The one you provided contained many more.

otto

2010-01-11 23:37

reporter   ~0001280

Sorry about the old log, this one is slighty smaller. I made sure there was no previous xdebug.log before starting this session.

http://www.mediafire.com/?movjqnuvno5

I will try to create a short script.

otto

2010-01-15 10:42

reporter   ~0001282

I've put up a testcase here: http://www.mediafire.com/?mnmdnjkwwkm

I put a breakpoint on line 6. Then expand and view the contents of the $form variable. This seems to put netbeans in an infinite loop. It's causing a forever growing xdebug.log file and uses all cpu. So I will create a ticket for this over there.

derick

2010-01-30 10:17

administrator   ~0001290

From the logs it looks like netbeans runs "property_get" after the script has ended... don't know why, but that is what happens.

derick

2010-02-03 10:43

administrator   ~0001315

(I can see this clearly as a netbeans issues btw)

Issue History

Date Modified Username Field Change
2010-01-11 21:46 otto New Issue
2010-01-11 21:46 otto Operating System => OS X 10.6.2
2010-01-11 21:46 otto PHP Version => 5.3.0
2010-01-11 21:46 otto Xdebug Version => 2.1.0-dev
2010-01-11 22:39 derick Note Added: 0001273
2010-01-11 22:39 derick Status new => resolved
2010-01-11 22:39 derick Resolution open => no change required
2010-01-11 22:39 derick Assigned To => derick
2010-01-11 22:49 otto Note Added: 0001275
2010-01-11 22:49 otto Status resolved => feedback
2010-01-11 22:49 otto Resolution no change required => reopened
2010-01-11 23:04 derick Note Added: 0001276
2010-01-11 23:12 otto Note Added: 0001277
2010-01-11 23:24 derick Note Added: 0001279
2010-01-11 23:37 otto Note Added: 0001280
2010-01-15 10:42 otto Note Added: 0001282
2010-01-30 10:17 derick Note Added: 0001290
2010-01-30 10:17 derick Status feedback => resolved
2010-01-30 10:17 derick Resolution reopened => no change required
2010-02-03 10:43 derick Note Added: 0001315
2010-02-03 11:20 derick Relationship added has duplicate 0000530
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)