View Issue Details

IDProjectCategoryView StatusLast Update
0000530XdebugUsage problems (Wrong Results)public2010-03-21 14:41
ReporterantonAssigned Toderick 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionno change required 
Product Version 
Target Version2.1.0RC1Fixed in Version 
Summary0000530: Socket Exception occoured Error with php 5.3.1+NB 6.8+xdebug 2.0.5 on opensuse 11.1 64bit
DescriptionAs you can see in the Title
I use:
- opensuse lunix 11.1 64 bit
- php 5.3.1
- xdebug 2.0.5 ( the problem exists with xebug 2.1.0beta too)
- Netbeans 6.8
- firefox 3.5.7 or 3.6

The whole time I had php 5.2.11 installed and it worked quite well.

Now I updated to php 5.3.1 and I get the following problems:
1. I set a breakpoint in my php file
2. I start to debug from netbeans
3. I see that Netbeans stops at the breakpoint (the green line)
4. Now I continue to step-through my code line by line
   Note: most of the time I do not see local variables,
         with php 5.2.11 I saw the variables.
5. After 1...n steps I get an error dialog from netbeans
   telling me:
   "Socket exception occoured" telling me to
    delete some watches and debugging is finished.

   
While this does not crash apache, I set it to blocker because
actually its unusable.
Note: I did the tests without using watches.


I sw
TagsNo tags attached.
Operating Systemopensuse 11.1 64 bit
PHP Version5.3.1

Relationships

duplicate of 0000520 resolvedderick NetBeans crashes at end of session 

Activities

derick

2010-02-03 11:20

administrator   ~0001316

This is a duplicate of 0000520, which seems like a bug in netbeans which I can't fix myself.

anton

2010-02-08 10:49

reporter   ~0001327

I submited this bug at netbeans.org too as:

https://netbeans.org/bugzilla/show_bug.cgi?id=180252

Pleas leave this issue open, at least for some
time, so we can get a true "its really solved"
statement some day.

Perhaps the netbeans guys should contact you directly?

anton

2010-02-11 13:12

reporter   ~0001330

The netbeans guys write at:

https://netbeans.org/bugzilla/show_bug.cgi?id=180252#c16

 " hmm, broken pipe after eval command which is long term xdebug problem: watches,
   baloon evaluation cause it. Anyway different issue and not bug in netbeans."

Could you tell me the issue number of this "long term xdebug problem"?

Or should it be fixed already?

I ask because I would really like to get it working.

anton

2010-02-17 08:53

reporter   ~0001353

The problem with netbeans is still here,

the netbeans guys refer to

http://bugs.xdebug.org/view.php?id=313

but in my sources do not have calls to unknown functions
or syntax errors.

Could you tell me what data you need?

I would like to help to fix this !

anton

2010-02-17 09:14

reporter   ~0001354

I just did e test with the following code:
    class MyClass {
         
         private $a = "b";
         private $b = null;
         
         public function __construct() {
            $this->b = 'b';
            $c = 'a' . 'b';
         }
         // I hoover in nb over this $a
         public function test($a) {
            echo "a ist: " . $a;
         }
      }
      
      $a = 1;
      $b = 2;
      $c = new MyClass();
      $f = 3;
      $c->test('gogo'); // this call***
      $c->test('gogo');

and when I am inside the function $c->test($a)
and I hoover over the parameter $a in netbeans I get a socket exception.

Question: where ca I upload atachments here??

derick

2010-02-17 09:46

administrator   ~0001357

@anton, you can't upload attachments. Please use http://pastebin.com (and select to not to expire the post) and post the link here. I absolutely need the remote_log though (See http://xdebug.org/docs/remote#remote_log on how to make them). Please make sure there is only 1 debug request in that log that shows the problem.

anton

2010-02-17 11:17

reporter   ~0001358

Hi I posted it

http://pastebin.com/f7329854c

Note that I saved the xdebug log file as soon as I got the error in netbeans
(I did not say 'stop debugging' in netbeans )

so you see at the end it looks like incomplete

I did the test with the actual development build of netbeans:
netbeans-trunk-nightly-201002170200-php-linux.sh

bfelipee

2010-02-18 10:46

reporter   ~0001359

there is new log on http://netbeans.org/bugzilla/show_bug.cgi?id=180252 from fzamboj. You can see that after calling eval the pipe got broken and netbeans threw SocketException.

netbeans log: http://netbeans.org/bugzilla/attachment.cgi?id=94278
xdebug log: http://netbeans.org/bugzilla/attachment.cgi?id=94279

anton

2010-03-01 12:46

reporter   ~0001373

I just did the tests with
- netbeans-trunk-nightly-201003010200-php-linux.sh
- xdebug 2.1.0beta3 (installed from pecl)

What I do:
- I step (debug) through my index.php file
- I hoover over a variable
- After the next F7 or F8 step I get the socket exception

NOTE: It seems that F7 and F8 are equel, or to be more precise
   the F8 key behave like F7 (jump into).

You can find the logfiles at

http://netbeans.org/bugzilla/show_bug.cgi?id=180252

The attachment link (with xdebug.log) is

http://netbeans.org/bugzilla/show_bug.cgi?id=180252

derick

2010-03-21 14:41

administrator   ~0001401

I've just tested this with the latest Xdebug (SVN) and the latest netbeans (the 20100321 nightly) and it works just fine. However, netbeans seems to be starting to use a bit more memory once in a while when eval is used. This is however something on the netbeans side. I am closing this issue as it's working fine, but netbeans really should not be using eval here, but instead property_get with the correct stack depth.

Issue History

Date Modified Username Field Change
2010-02-03 09:22 anton New Issue
2010-02-03 09:22 anton Operating System => opensuse 11.1 64 bit
2010-02-03 09:22 anton PHP Version => 5.3.1
2010-02-03 09:22 anton Xdebug Version => 2.1.0beta1
2010-02-03 11:20 derick Note Added: 0001316
2010-02-03 11:20 derick Relationship added duplicate of 0000520
2010-02-03 11:20 derick Duplicate ID 0 => 520
2010-02-03 11:20 derick Status new => resolved
2010-02-03 11:20 derick Resolution open => duplicate
2010-02-03 11:20 derick Assigned To => derick
2010-02-08 10:49 anton Note Added: 0001327
2010-02-08 10:49 anton Status resolved => feedback
2010-02-08 10:49 anton Resolution duplicate => reopened
2010-02-11 13:12 anton Note Added: 0001330
2010-02-17 08:53 anton Note Added: 0001353
2010-02-17 09:14 anton Note Added: 0001354
2010-02-17 09:46 derick Note Added: 0001357
2010-02-17 11:17 anton Note Added: 0001358
2010-02-18 10:46 bfelipee Note Added: 0001359
2010-03-01 12:46 anton Note Added: 0001373
2010-03-20 23:50 derick Target Version => 2.1.0RC1
2010-03-21 14:41 derick Note Added: 0001401
2010-03-21 14:41 derick Status feedback => resolved
2010-03-21 14:41 derick Resolution reopened => no change required
2010-03-21 14:41 derick Duplicate ID 520 => 0
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)