View Issue Details

IDProjectCategoryView StatusLast Update
0000536XdebugUsage problems (Wrong Results)public2010-02-14 15:14
ReporteralcaeusAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.0.0dev 
Target VersionFixed in Version 
Summary0000536: Only partial headers are sent when xdebug is enabled
DescriptionWhen enabling XDebug, I noticed that session handling does not work correctly. Digging into the problem, I tested the following script:
<?php

session_start();
echo session_id();
session_write_close();

?>

With XDebug enabled, the session ID changed with every request, when it was disabled, the session ID remained the same. The session cookie was not set when XDebug was enabled.
The response headers are incomplete when XDebug is enabled. Here the original Response Headers without XDebug:
Without xdebug:
Date: Sun, 14 Feb 2010 13:32:32 GMT
Server: Apache/2.2.14 (Win32) PHP/5.3.1
X-Powered-By: PHP/5.3.1
Set-Cookie: PHPSESSID=bi249o18l6tengq726iauv7l43; path=/
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate, post-check=0, pre-check=0
Pragma: no-cache
Keep-Alive: timeout=5, max=100
Connection: Keep-Alive
Transfer-Encoding: chunked
Content-Type: text/html

Here the headers for the same request with XDebug enabled:
Date: Sun, 14 Feb 2010 13:34:32 GMT
Server: Apache/2.2.14 (Win32) PHP/5.3.1
Keep-Alive: timeout=5, max=99
Connection: Keep-Alive
Transfer-Encoding: chunked
Content-Type: text/html

This effectively keeps me from debugging any application which relies on PHP's session handling.
TagsNo tags attached.
Operating System
PHP Version5.3.1

Relationships

duplicate of 0000532 closed XDebug breaks header() function 

Activities

alcaeus

2010-02-14 13:44

reporter   ~0001331

Actually, now that I take a look at it, this may be related to 0000532.

derick

2010-02-14 15:14

administrator   ~0001332

Yeah, this is the same issue as bug 0000532, so closing this one as duplicate. I can reproduce this, but it does *not* happen with non-threaded SAPIs.

Issue History

Date Modified Username Field Change
2010-02-14 13:43 alcaeus New Issue
2010-02-14 13:43 alcaeus PHP Version => 5.3.1
2010-02-14 13:43 alcaeus Xdebug Version => 2.1.0beta1
2010-02-14 13:44 alcaeus Note Added: 0001331
2010-02-14 15:14 derick Note Added: 0001332
2010-02-14 15:14 derick Relationship added duplicate of 0000532
2010-02-14 15:14 derick Duplicate ID 0 => 532
2010-02-14 15:14 derick Status new => resolved
2010-02-14 15:14 derick Resolution open => duplicate
2010-02-14 15:14 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)