View Issue Details

IDProjectCategoryView StatusLast Update
0000547XdebugUsage problems (Wrong Results)public2010-03-17 00:18
Reporterc960657Assigned Toderick 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionduplicate 
Product Version2.0.0dev 
Target VersionFixed in Version 
Summary0000547: Cachegrind file reports cost ~4293967300
DescriptionMost of the time the profiler works fine, but occasionally (perhaps it 25% of the requests) it reports a very large number 4293967300 +/- 300 of a single or a few functions.

Here is a part of the cachegrind output file:

fl=php:internal
fn=php::function_exists
330 3

fl=php:internal
fn=php::function_exists
334 2

fl=php:internal
fn=php::function_exists
330 2

fl=php:internal
fn=php::function_exists
334 4293967300

fl=php:internal
fn=php::function_exists
330 1

fl=php:internal
fn=php::function_exists
334 3

fl=php:internal
fn=php::function_exists
330 1

fl=php:internal
fn=php::function_exists
334 2
Additional InformationI am running PHP 5.2.11 on WinXP with Xcache 1.3.0. I have seen the problem using Xdebug 2.0.3 and 2.1.0beta3.
TagsNo tags attached.
Operating SystemWindows XP
PHP Version5.2.10

Relationships

duplicate of 0000357 resolvedderick Profiler shows huge times for certain calls 

Activities

c960657

2010-03-15 12:10

reporter   ~0001383

Sorry, I submitted this report by mistake. It is a duplicate of issue 0000357.

derick

2010-03-17 00:18

administrator   ~0001386

As you said, a duplicate of 0000357.

Issue History

Date Modified Username Field Change
2010-03-15 12:09 c960657 New Issue
2010-03-15 12:09 c960657 Operating System => Windows XP
2010-03-15 12:09 c960657 PHP Version => 5.2.10
2010-03-15 12:09 c960657 Xdebug Version => 2.1.0beta1
2010-03-15 12:10 c960657 Note Added: 0001383
2010-03-17 00:18 derick Note Added: 0001386
2010-03-17 00:18 derick Relationship added duplicate of 0000357
2010-03-17 00:18 derick Duplicate ID 0 => 357
2010-03-17 00:18 derick Status new => resolved
2010-03-17 00:18 derick Resolution open => duplicate
2010-03-17 00:18 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)