View Issue Details

IDProjectCategoryView StatusLast Update
0000560XdebugUsage problems (Wrong Results)public2010-04-12 10:39
ReporterstanvAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.1.0RC1 
Target VersionFixed in Version 
Summary0000560: base64 encoding / "child count update" / PDT bug
DescriptionSorry to open this again, I see multiple instances of this bug but they're all closed so I couldn't leave a comment.

Derick, I appreciate the bug is in PDT as per your analysis, however let's consider the real-world implications of this break. Encoding the property with base64 should make PDT work again, if I understand correctly?

PDT2 has been around for a long time, but it still has many regressions and performance issues compared to PDT1. PDT1 is not updated any longer, so even if they could fix the issue, they won't.

On the other hand, older versions of XDebug for PHP 5.3, which are compatible with PDT are not compatible with PHP 5.3 (the header() bug). I tried to download XDebug 2.0.5, but the 2.0.5 links downloads a DLL with version 2.1.0

The result of this is I had to revert my development environment back to PHP 5.2.x series in order to do my work. If something can be done so XDebug would work in PDT1 with the existing PDT limitations, the way it worked for years before, would be highly appreciated.

Thank you!
TagsNo tags attached.
Operating SystemWindows XP 32-bit / PDT 1.x
PHP Version5.3.2

Relationships

duplicate of 0000556 resolvedderick An internal error occurred during: "child count update". 

Activities

derick

2010-04-12 10:39

administrator   ~0001440

Please don't create issues because you can't reopen the bug. Use the mailinglist if you want to discuss things.

Issue History

Date Modified Username Field Change
2010-04-08 12:54 stanv New Issue
2010-04-08 12:54 stanv Operating System => Windows XP 32-bit / PDT 1.x
2010-04-08 12:54 stanv PHP Version => 5.3.2
2010-04-08 12:54 stanv Xdebug Version => 2.1.0beta1
2010-04-12 10:39 derick Note Added: 0001440
2010-04-12 10:39 derick Relationship added duplicate of 0000556
2010-04-12 10:39 derick Duplicate ID 0 => 556
2010-04-12 10:39 derick Status new => resolved
2010-04-12 10:39 derick Resolution open => duplicate
2010-04-12 10:39 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)