View Issue Details

IDProjectCategoryView StatusLast Update
0000564XdebugUsage problems (Wrong Results)public2010-07-23 23:27
Reporterricardok1Assigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.1.0RC1 
Target VersionFixed in Version 
Summary0000564: Xdebug 2.1.0.RC1 crash apps (blank screen & no error on log)
DescriptionWhen I switched from 2.0.5 to 2.1.0.RC1 my application stop working. Delivery a blank screen and no error reported on logs.
Additional Informationall VC6 x86
TagsNo tags attached.
Operating SystemWindows XP SP3 x86
PHP Version5.3.2

Activities

derick

2010-04-20 14:00

administrator   ~0001454

You need to provide a lot more information, such as a short reproducable script, as well as a backtrace: http://bugs.php.net/bugs-generating-backtrace-win32.php

ricardok1

2010-04-22 20:14

reporter   ~0001457

It appears that the problem is with xcache 1.3.0 but I'm not sure...

derick

2010-04-22 20:18

administrator   ~0001458

If you remove xcache from the configuration, does the same issue happen then?

ricardok1

2010-04-22 21:10

reporter   ~0001459

If I remove xcache 1.3.0 it works normally.

With xdebug 2.0.5 + xcache 1.3.0 its ok - no problem.

The "youth" of PHP 5.3.x branch creates many compatibility issues, don't you think? In the opcoders cache it destroys our believe in the stability...

derick

2010-04-22 21:16

administrator   ~0001460

Well, it makes little sense to use xcache with Xdebug together anyway. I also think APC is *much* more stable anyway. In any case, supporting all sorts of opcode caches isn't something I want to spend time on so I'll be closing this report.

ricardok1

2010-04-22 21:17

reporter   ~0001461

Thread 248 - System ID 11032
Entry point msvcr90!_endthreadex+6f
Create time 22-04-2010 22:12:27
Time spent in user mode 0 Days 0:0:0.0
Time spent in kernel mode 0 Days 0:0:0.0






Function Arg 1 Arg 2 Arg 3 Source
php_xdebug!xdebug_init_oparray+23 20962290 008eeb62 013a0e78
php_xcache_1_3_0_5_3_0_vc6+7972 013a0e78 20962290 205aee50
php5ts!zend_llist_apply_with_argument+22 00d9d240 01477960 20962290
php_xcache_1_3_0_5_3_0_vc6+7951 00000000 00000000 00000000




PHP_XDEBUG!XDEBUG_INIT_OPARRAY+23WARNING - DebugDiag was not able to locate debug symbols for php_xdebug.dll, so the information below may be incomplete.



In httpd__PID__11096__Date__04_22_2010__Time_10_12_32PM__93__Second_Chance_Exception_C0000005.dmp the assembly instruction at php_xdebug!xdebug_init_oparray+23 in C:\AppServ\php5\ext\php_xdebug.dll from Derick Rethans has caused an access violation exception (0xC0000005) when trying to write to memory location 0x00000000 on thread 248

Module Information
Image Name: C:\AppServ\php5\ext\php_xdebug.dll Symbol Type: Export
Base address: 0x01440000 Time Stamp: Thu Jul 02 10:31:11 2009
Checksum: 0x00000000 Comments: Thanks to Derick Rethans, Ilia Alshanetsky, Harald Radi
COM DLL: False Company Name: Derick Rethans
ISAPIExtension: False File Description: Xdebug
ISAPIFilter: False File Version: 2.0.5
Managed DLL: False Internal Name: php_xdebug.dll
VB DLL: False Legal Copyright: Copyright © 2002-2008 Derick Rethans
Loaded Image Name: php_xdebug.dll Legal Trademarks:
Mapped Image Name: C:\AppServ\php5\ext\php_xdebug.dll Original filename: php_xdebug.dll
Module name: php_xdebug Private Build:
Single Threaded: False Product Name: Xdebug
Module Size: 160,00 KBytes Product Version: 2.0.5
Symbol File Name: php_xdebug.dll Special Build: &

ricardok1

2010-04-22 21:30

reporter   ~0001462

With PHP 5.3.x, the APC is a beta version to say the least. Pierre didn't get stability in operation on Win32. I saw others with the same problem.

My production server is a Win2008 x64 but with Apache+PHP x86 - xdedug will work with this hybrid x64 / x86 system?

ricardok1

2010-04-22 21:35

reporter   ~0001464

With 2.1.0.rc1:


Thread 0 - System ID 8412
Entry point httpd+222d
Create time 22-04-2010 20:59:12
Time spent in user mode 0 Days 0:0:0.640
Time spent in kernel mode 0 Days 0:0:1.15






Function Arg 1 Arg 2 Arg 3 Source
ntdll!KiRaiseUserExceptionDispatcher+37 7c90cffa 7c809c2b 00000005
ntdll!KiFastSystemCall+3 7c809c2b 00000005 01e4ba30
ntdll!NtClose+c 00000005 01e4ba30 015020cf
kernel32!CloseHandle+51 00000005 00000002 04180020
php_xcache_1_3_0_5_3_0_vc6+20cf 01e4bbc0 01460f70 003d4068
php_xcache_1_3_0_5_3_0_vc6+d1c2 01e4ba80 01513438 00000000
php_xcache_1_3_0_5_3_0_vc6+d24a 00000000 00000000 00000000




In httpd__PID__4380__Date__04_22_2010__Time_09_06_23PM__546__Second_Chance_Exception_C0000008.dmp the assembly instruction at ntdll!KiRaiseUserExceptionDispatcher+37 in C:\WINDOWS\system32\ntdll.dll from Microsoft Corporation has caused an unknown exception (0xc0000008) on thread 0



This exception originated from php_xcache_1_3_0_5_3_0_vc6+20cf. Module Information
Image Name: C:\AppServ\php5\ext\php_xcache_1.3.0-5.3.0-vc6.dll Symbol Type: Export
Base address: 0x01500000 Time Stamp: Tue Aug 04 04:07:23 2009
Checksum: 0x00000000 Comments:
COM DLL: False Company Name: The PHP Group
ISAPIExtension: False File Description: php_xcache.dll
ISAPIFilter: False File Version: 5.3.0
Managed DLL: False Internal Name: XCACHE extension
VB DLL: False Legal Copyright: Copyright © 1997-2009 The PHP Group
Loaded Image Name: php_xcache_1.3.0-5.3.0-vc6.dll Legal Trademarks: PHP
Mapped Image Name: C:\AppServ\php5\ext\php_xcache_1.3.0-5.3.0-vc6.dll Original filename: php_xcache.dll
Module name: php_xcache_1_3_0_5_3_0_vc6 Private Build:
Single Threaded: False Product Name: PHP
Module Size: 88,00 KBytes Product Version: 5.3.0
Symbol File Name: php_xcache_1.3.0-5.3.0-vc6.dll Special Build: &

arekanderu

2010-06-03 01:16

reporter   ~0001488

Last edited: 2010-06-03 01:20

Hello

I am using ubuntu 10.04 x64 and installed Xdebug v2.1.0rc today. Unfortunately I am experiencing this problem as well.

I have a project (based on zend framework) which i can step through the breakpoints just fine but when execution completes i see blank screen. If i disable xdebug output is just fine.

I do not have xcache enabled (or at least thats what phpinfo reports).

In addition, when i have xdebug enabled and I try to run my phpinfo.php (which simply contains a call to phpinfo();) the script instead of executing i get a message from browser to download it, like the server does not know how to handle php files. If, once again, i disable xdebug, phpinfo.php executes just fine.

Please let me know what further info i can provide to help resolve this problem.

PHP Version: PHP 5.3.2-1ubuntu4.2 with Suhosin-Patch (cli) (built: May 13 2010 20:03:45)

derick

2010-07-08 10:18

administrator   ~0001520

Can you guys please check the latest proper release (2.1.0) as well? I can't reproduce this.

ricardok1

2010-07-09 20:47

reporter   ~0001527

Derick, the version 2.1.0 works well with xcache and eaccelerator.
No more crashes!
Thanks!

ricardok1

2010-07-09 20:49

reporter   ~0001528

Tested on:
 Win32 + PHP 5.3.2 VC6 TS + xcache 1.3.0 / 2.0 dev
and
 Win32 + PHP 5.3.2 VC6 TS + eaccelerator 0.9.6.1

ricardok1

2010-07-09 21:18

reporter   ~0001529

Donation: 4LE973636H4339447

derick

2010-07-23 23:27

administrator   ~0001542

All right; thanks for testing (and the donation). Closing then.

Issue History

Date Modified Username Field Change
2010-04-14 19:25 ricardok1 New Issue
2010-04-14 19:25 ricardok1 Operating System => Windows XP SP3 x86
2010-04-14 19:25 ricardok1 PHP Version => 5.3.2
2010-04-14 19:25 ricardok1 Xdebug Version => 2.1.0rc1
2010-04-20 14:00 derick Note Added: 0001454
2010-04-20 14:00 derick Status new => feedback
2010-04-22 20:14 ricardok1 Note Added: 0001457
2010-04-22 20:18 derick Note Added: 0001458
2010-04-22 21:10 ricardok1 Note Added: 0001459
2010-04-22 21:16 derick Note Added: 0001460
2010-04-22 21:16 derick Status feedback => resolved
2010-04-22 21:16 derick Resolution open => suspended
2010-04-22 21:16 derick Assigned To => derick
2010-04-22 21:17 ricardok1 Note Added: 0001461
2010-04-22 21:17 ricardok1 Status resolved => feedback
2010-04-22 21:17 ricardok1 Resolution suspended => reopened
2010-04-22 21:30 ricardok1 Note Added: 0001462
2010-04-22 21:35 ricardok1 Note Added: 0001464
2010-06-03 01:16 arekanderu Note Added: 0001488
2010-06-03 01:17 arekanderu Note Edited: 0001488
2010-06-03 01:18 arekanderu Note Edited: 0001488
2010-06-03 01:19 arekanderu Note Edited: 0001488
2010-06-03 01:20 arekanderu Note Edited: 0001488
2010-07-08 10:18 derick Note Added: 0001520
2010-07-09 20:47 ricardok1 Note Added: 0001527
2010-07-09 20:49 ricardok1 Note Added: 0001528
2010-07-09 21:18 ricardok1 Note Added: 0001529
2010-07-23 23:27 derick Note Added: 0001542
2010-07-23 23:27 derick Status feedback => resolved
2010-07-23 23:27 derick Resolution reopened => fixed
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)