View Issue Details

IDProjectCategoryView StatusLast Update
0000588XdebugUsage problems (Wrong Results)public2014-02-27 20:03
ReporterkipelovetsAssigned Toderick 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0000588: native functions overweight in xdebug profiler output
Descriptionhi

i have a problem with xdebug on a FreeBSD server. on that server xdebug profiler's cachegrind files say that executing time of native functions (such as DOMDocument::load() or XSLTStylesheet::importStylesheet) is about 50% of total script execution time. and with profiler turned off those functions work for less than 0.1%

on my own Ubuntu computer there are no such deviations in profiler output, so i think the problem is connected with some configuration-specific issues. where should i look to identify that problem?
TagsNo tags attached.
Operating SystemFreeBSD
PHP Version5.3.2

Activities

derick

2014-02-27 20:03

administrator   ~0002723

I don't think there is a bug, if this is still a problem, please refer to the support mechanisms at http://xdebug.org/support.php (mailinglist is probably best).

Issue History

Date Modified Username Field Change
2010-06-21 14:02 kipelovets New Issue
2010-06-21 14:02 kipelovets Operating System => FreeBSD
2010-06-21 14:02 kipelovets PHP Version => 5.3.2
2010-06-21 14:02 kipelovets Xdebug Version => 2.0.5
2014-02-27 20:03 derick Note Added: 0002723
2014-02-27 20:03 derick Status new => resolved
2014-02-27 20:03 derick Resolution open => no change required
2014-02-27 20:03 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)