View Issue Details

IDProjectCategoryView StatusLast Update
0000593XdebugInstallationpublic2010-07-23 23:04
ReporterlasereyesAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version2.1.0 
Target VersionFixed in Version 
Summary0000593: About install the xdebug
Descriptionwhen I restart the apache , I get the error logs as follow:
 


Warning: Xdebug MUST be loaded as a Zend extension in Unknown on line 0



Warning: Xdebug MUST be loaded as a Zend extension in Unknown on line 0

Failed loading xdebug.so: xdebug.so: cannot open shared object file: No such file or directory
Failed loading xdebug.so: xdebug.so: cannot open shared object file: No such file or directory
Failed loading xdebug.so: xdebug.so: cannot open shared object file: No such file or directory
Failed loading xdebug.so: xdebug.so: cannot open shared object file: No such file or directory


Warning: Xdebug MUST be loaded as a Zend extension in Unknown on line 0



Warning: Xdebug MUST be loaded as a Zend extension in Unknown on line 0

Failed loading xdebug.so: xdebug.so: cannot open shared object file: No such file or directory
Failed loading xdebug.so: xdebug.so: cannot open shared object file: No such file or directory


Warning: Xdebug MUST be loaded as a Zend extension in Unknown on line 0



Warning: Xdebug MUST be loaded as a Zend extension in Unknown on line 0

Failed loading xdebug.so: xdebug.so: cannot open shared object file: No such file or directory
Failed loading xdebug.so: xdebug.so: cannot open shared object file: No such file or directory
Failed loading xdebug.so: xdebug.so: cannot open shared object file: No such file or directory
Failed loading xdebug.so: xdebug.so: cannot open shared object file: No such file or directory


Warning: Xdebug MUST be loaded as a Zend extension in Unknown on line 0



Warning: Xdebug MUST be loaded as a Zend extension in Unknown on line 0

Failed loading xdebug.so: xdebug.so: cannot open shared object file: No such file or directory
Failed loading xdebug.so: xdebug.so: cannot open shared object file: No such file or directory

 
.......
 
 
 

Additional Informationphp version: 5.3.2
xdebug: 2.1.0 ==> download from ( http://xdebug.org/download.php)
 
install:
 
tar -xzvf xdebug-2.1.0.tgz
cd xdebug-2.1.0
phpize
./configure
make
make install
 
update the php.ini
 
zend_extension="/opt/local/php/lib/php/extensions/no-debug-non-zts-20090626/xdebug.so"
xdebug.profiler_output_dir = "/tmp/xdebug/"
xdebug.profiler_enable = Off
xdebug.profiler_enable_trigger = 1
 
 
[root@localhost xdebug-2.1.0]# php -m
[PHP Modules]
apc
Core
ctype
curl
date
dom
ereg
fileinfo
filter
hash
iconv
json
ldap
libxml
memcache
mysql
pcre
PDO
pdo_mysql
pdo_sqlite
Phar
posix
Reflection
session
SimpleXML
sockets
SPL
SQLite
sqlite3
standard
tokenizer
xdebug
xml
xmlreader
xmlwriter
 
[Zend Modules]
Xdebug

 
 
I can load the xdebug module, but the apache log also exist, I hope you can tell me how to deal with the issue.
 
Thank you.
TagsNo tags attached.
Operating Systemlinux (centos 5.4)
PHP Version5.3.2

Activities

derick

2010-07-23 20:44

administrator   ~0001540

You're trying to load it twice somehow. This is not a bug.

Issue History

Date Modified Username Field Change
2010-07-12 07:43 lasereyes New Issue
2010-07-12 07:43 lasereyes Operating System => linux (centos 5.4)
2010-07-12 07:43 lasereyes PHP Version => 5.3.2
2010-07-12 07:43 lasereyes Xdebug Version => 2.1.0
2010-07-23 20:44 derick Note Added: 0001540
2010-07-23 23:04 derick Status new => resolved
2010-07-23 23:04 derick Resolution open => no change required
2010-07-23 23:04 derick Assigned To => derick