View Issue Details

IDProjectCategoryView StatusLast Update
0000603XdebugFeature/Change requestpublic2016-12-12 19:08
ReporterDraeliAssigned Toderick 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionwon't fix 
Product Version2.1.0 
Target VersionFixed in Version 
Summary0000603: Idea : change CSS style presentation
DescriptionEn :
Actually 'xdebug-var-dump' class is use to have personnalized Css but it's not possible to do deep style change, can you used 'span' (and a named class on each different tag) instead tag 'i/u/small' and other ?

Fr :
Actuellement la classe 'xdebug-var-dump' est utilisé pour personnalisé le style CSS mais il n'est pas possible de changer le style en profondeur. Pourriez vous utilisé la balise 'span' (et une classe spécifique pour chaque balise différente) à la place des tags comme 'i/u/small' et autres ?

Example :
----

Actually (capture with Firebug) :
<pre dir="ltr" class="xdebug-var-dump">
    object(api\Obj)[17]
    private '__arrMethod' <font color="#888a85">=></font>
    array 'coucou' <font color="#888a85">=></font>
    object(Closure)[16]
    public 'plop' <font color="#888a85">=></font> <small>string</small> <font color="#cc0000">'je suis la variable plop'</font> (length=24)


After :
<pre dir="ltr" class="xdebug-var-dump">
    <span class="typeObject">object</span><span class="syntaxBracketOpen">(</span><span class="objectName">api\Obj</span><span class="syntaxBracketEnd">)</span><span class="syntaxHookOpen">[</span><span class="id">17</span><span class="syntaxHookEnd">]</span>
    <span class="varAccessPrivate">private</span> <span class="varName">'__arrMethod'</span> <span class="as">=></span>
    <span class="typeArray">array</span> <span class="arrayKey">'coucou'</span> <span class="as">=></span>
    <span class="typeObject">object</span><span class="syntaxBracketOpen">(</span><span class="objectName">Closure</span><span class="syntaxBracketEnd">)</span><span class="syntaxHookOpen">[</span><span class="id">16</span><span class="syntaxHookEnd">]</span>
    <span class="varAccessPublic">public</span> <span class="varName">'plop'</span> <span class="as">=></span> <span class="typeString">string</span> <span class="varValue">'je suis la variable plop'</span> <span class="length">(length=24)</span>


with a Css style
<style type="text/css">
.xdebug-var-dump{border:1px dotted #00f;color:#000;padding:4px;background:#eee;}
.xdebug-var-dump .syntaxBracketOpen{color:#1a8f40;}
.xdebug-var-dump .syntaxBracketEnd{color:#1a8f40;}
.xdebug-var-dump .objectName{font-style:italic;color:#0c3f3e;}
.xdebug-var-dump .syntaxHookOpen{color:#9f1d6c;}
.xdebug-var-dump .syntaxHookEnd{color:#9f1d6c;}
.xdebug-var-dump .id{color:#56235f;}
.xdebug-var-dump .as{color:#8f8411;}
.xdebug-var-dump .length{font-size:.9em;color:#210d6f;}
.xdebug-var-dump .varAccessPrivate{color:#9f1326;}
.xdebug-var-dump .varAccessProtected{color:#13469f;}
.xdebug-var-dump .varAccessPublic{color:#139f5b;}
.xdebug-var-dump .varName{color:#7f1769;}
.xdebug-var-dump .varValue{color:#ef0e17;}
.xdebug-var-dump .typeObject{font-weight:700;color:#4f4205;}
.xdebug-var-dump .typeArray{color:#8f641a;}
.xdebug-var-dump .typeString{color:#6f670d;}
.xdebug-var-dump .typeBoolean{color:#5c6f0d;}
.xdebug-var-dump .arrayKey{color:#279f91;}
</style>
TagsNo tags attached.
Operating System
PHP Version5.3.3

Activities

derick

2010-08-13 08:24

administrator   ~0001555

I could; but it requires a *lot* of extra data to be generated, something that I rather not do. Is this really important?

Draeli

2010-08-13 10:12

reporter   ~0001560

I don't know if that's absolutly important but I know I win time in my development debug when I can quickly repair an error type and read all part of error. With a color syntax more advanced, I think mind can associate more quickly an error group.

Example : I forgot a syntax point, I can associate the associate type error with red color. Now, next time, I see a red error, mind knows "oh, damn error syntax" and read details error isn't necessary.

In my error handler, actually I associate colors with error type (Exception, Php type error, ....) and I see the time winning by this process.

derick

2016-12-12 19:08

administrator   ~0004039

I am closing this, because it will generate a lot of extra HTML, and nobody else requested this feature.

Issue History

Date Modified Username Field Change
2010-08-02 15:14 Draeli New Issue
2010-08-02 15:14 Draeli PHP Version => 5.3.3
2010-08-02 15:14 Draeli Xdebug Version => 2.1.0
2010-08-13 08:24 derick Note Added: 0001555
2010-08-13 10:12 Draeli Note Added: 0001560
2016-12-12 19:08 derick Note Added: 0004039
2016-12-12 19:08 derick Status new => resolved
2016-12-12 19:08 derick Resolution open => won't fix
2016-12-12 19:08 derick Assigned To => derick