View Issue Details

IDProjectCategoryView StatusLast Update
0000604XdebugUsage problems (Wrong Results)public2011-08-17 18:44
ReportercitrusmooseAssigned Toderick 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionduplicate 
Product Version2.1.0 
Target VersionFixed in Version 
Summary0000604: profiler_output_name: Using %R causes no output on some requests
DescriptionIt appears that if I use %R in profiler_output_name, my GET requests (which have a good bit of parameters) won't produce any output. However, the ajax POST requests that are triggered on the GET requests' completion do have output. I'm assuming this has something to do with file name length. POST requests obviously won't have very long names, while GET requests will.
TagsNo tags attached.
Operating SystemLinux (SUSE SLES 10 SP2)
PHP Version5.3.3

Relationships

duplicate of 0000693 resolvedderick Profiling: cachegrind files not written when filename exceeds 260 characters 

Activities

derick

2010-08-13 08:27

administrator   ~0001558

Yeah, filename length is most certainly the case. Could you provide a long GET URL please to shows this issue?

citrusmoose

2010-08-13 14:43

reporter   ~0001561

/test/atest.php?var01=01&var02=02&var03=03&var04=04&var05=05&var06=06&var07=07&var08=08&var09=09&var10=10&var11=11&var12=12&var13=13&var14=14&var15=15&var16=16&var17=17&var18=18&var19=19&var20=20&var21=21&var22=22&var23=23&var24=24&var25=25&

Being that 255 is the longest file name you can have, this URL is one character over the longest request you can have without it failing to produce output. This is assuming your profiler_output_name is set to "cachegrind.out.%R".

derick

2011-08-17 18:44

administrator   ~0001789

This is a duplicate of 0000693, which is fixed for 2.1.3 and 2.2.

Issue History

Date Modified Username Field Change
2010-08-05 15:25 citrusmoose New Issue
2010-08-05 15:25 citrusmoose Operating System => Linux (SUSE SLES 10 SP2)
2010-08-05 15:25 citrusmoose PHP Version => 5.3.3
2010-08-05 15:25 citrusmoose Xdebug Version => 2.1.0
2010-08-13 08:27 derick Note Added: 0001558
2010-08-13 14:43 citrusmoose Note Added: 0001561
2011-08-17 18:44 derick Note Added: 0001789
2011-08-17 18:44 derick Relationship added duplicate of 0000693
2011-08-17 18:44 derick Status new => resolved
2011-08-17 18:44 derick Resolution open => duplicate
2011-08-17 18:44 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)